OctoPrint refuses to connect

What is the problem?

When trying to connect to OctoPrint, I get the message "(ip address) refused to connect." I had upgraded to the latest OctoPrint a couple of weeks ago but I am still running Python2. I haven't used this printer for a while so I don't know why it refuses to connect. I have never had this problem before. I can ping the ip address so I know that it sees me, it just doesn't like me anymore.

What did you already try to solve it?

pinged the address to see if it can hear me and it does, ran Angry IP to see if the address is still good and it is, rebooted several times but I still get the same message.

Have you tried running in safe mode?

nope - don't know how

Did running in safe mode solve the problem?

WRITE HERE

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Can't open OctoPrint to download Systeminfo Bundle

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint ver. 1.6.1, CR-10s printer, Firmware Marlin TH3D 2.35, Chrome, Octopi, have a 7" screen connected directly to the Raspberry Pi (ver. 3B) but cannot connect using Chrome from 7" screen or from Mac laptop using either Safari or Brave.

As you can ping the box chances are you can ssh into it, too. (putty)
Please do and check from within:

sudo systemctl status octoprint status check
sudo systemctl restart octoprint restart the server

ping 1.1.1.1 connection to the internet?

cat /home/pi/.octoprint/logs/octoprint.log print the entire octoprint.log file to screen (you can copy it)
cat /home/pi/.octoprint/logs/octoprint.log|grep err print all the lines with "error"

Well, for whatever reason, OctoPi, OctoPrint, or Elmer Fudd changed the IP address. When I opened terminal on the Pi, it showed 4 different ways to log into OctoPrint and one of them was a new IP address. I opened that new address and was able to login as before. I've seen stranger things happen but that's usually on TV...

Some routers restart from time to time. Often devices get new IP addresses.