Octoprint replacing Gcode lines in files with Webcamd messages

What is the problem?

  • 2nd occurrence / same printer - M112 on MK3S
  • downloaded gcode file - found a large section of gcode missing and replaced with recurring webcamd messages inside the gcode file
  • happened twice about 1 month apart on completely different files

What did you already try to solve it?

1st time this happened, i thought it was a fluke and just deleted / recopied the correct file back to octoprint and kept on printing
2nd time this happened (about a month later - today ) did a diff on the files and found the recurring webcamd messages in the gcode file...also noticed the recurring webcamd messages have June 12 timestamps...I confirmed via linux command line (and not rebooting the PI) that the time is correct on the Pi..ie, Oct 3

Have you tried running in safe mode?

no...printer runs fine after replacing corrupted file

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20221003212752.zip (717.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

  • octoprint - 1.8.3
  • octopi - 0.18
  • printer - mk3s
  • firmware - 3.10.0-4481
  • Rpi - Zero2W
  • browser - Chrome
  • OS - windows 10

I have no ideas thus far, but congrats on a very interesting bug.

For this issue seems to appear on random occasions, you may run with disabled 3rd party plugins: Sticky Pad and System Command Editor for a certain time.

Hehe…thx, I thought this one was worthy of posting / asking for help as well as it is odd the gcode file was modified somehow

Have you run any sort of filesystem checks or tried a different SD card?

It really seems like something on the filesystem is very confused. It is also not likely going to be something OctoPrint is doing - webcamd and OctoPrint are completely separate processes & would not normally interact. OctoPrint streams from the printing gcode file, or writes to it when you upload one, and then I guess webcamd also tried to write and the filesystem got itself in a twist somehow.

that makes sense. I have a bunch of these running identical Octopi/Octoprint. Was thinking about just reloading from a fresh build.

the other interesting thing is that I have had all the webcam functionality turned off in setup from the initial build long ago.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.