Octoprint Reporting Disk Full

Octoprint is reporting that my disk is nearly full and can't do an update (running on a Dell desktop with Ubuntu 20.04).
For example I get this message when I try and update packages from the web interface:

  • Python package installation Folder (/home/octoprint/python_venvs/octoprint1/lib/python3.8/site-packages): 71.5MB free
  • Plugin folder (/home/octoprint/octoprint_basedirs/instance1/plugins): 71.5MB free
  • System temporary files (/tmp): 71.5MB free

However, when I run df:
Filesystem Size Used Avail Use% Mounted on
udev 3.9G 0 3.9G 0% /dev
tmpfs 790M 1.7M 788M 1% /run
/dev/sda5 228G 115G 102G 53% /
tmpfs 3.9G 88M 3.8G 3% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup
/dev/loop5 98M 98M 0 100% /snap/core/9993
/dev/loop6 9.2M 9.2M 0 100% /snap/canonical-livepatch/95
/dev/loop0 31M 31M 0 100% /snap/snapd/9279
/dev/loop3 55M 55M 0 100% /snap/core18/1880
/dev/loop1 50M 50M 0 100% /snap/snap-store/467
/dev/loop8 30M 30M 0 100% /snap/snapd/8790
/dev/loop7 56M 56M 0 100% /snap/core18/1885
/dev/loop2 256M 256M 0 100% /snap/gnome-3-34-1804/36
/dev/loop4 63M 63M 0 100% /snap/gtk-common-themes/1506
/dev/sda1 511M 4.0K 511M 1% /boot/efi
tmpfs 790M 40K 790M 1% /run/user/1000

I appears my disk still has 102 GB available? Why the message?

Is that the value you get shown at the bottom of the file list in the left sidebar?

Yes, that shows the same amount free...

Sorry... I rebooted the server... that seems to have worked... I should have tried that first!

1 Like