OctoPrint Resets mid-print / randomly no "cause"

What is the problem?

First of all I'm depressed and forget easily. Including my account passwords, google cant seem to get them into JuiceSSH properly.

It literally started happening spontanusly but within 48 hours of updates. I had the best run of good prints and now 1/8 success. Early problems said that my printer requested the same line over and over. Later I caught OP restarting corelating with a freeze of printer movement. Now it resets by itself, not even connected to printer, not doing anything...

What did you already try to solve it?

I tried to roll-back update (easy to go foward, going back takes a computer scientist).
I swapped the USB port.
I reduced baud to 56k.
Enabled Serial.log - oh I'm scared it logs everything!!
Removed the USB keyboard that was assotiated with the plugin.
Safe mode, thx for reminding me.
Remove all my hair.
Discover serial.log is useless, it is cleared on every boot so a post-mortem is impossible - WTG....

Find out it isn't in safe mode for some reason tyring again, ok now no plugins.
Giving up on OP, using SD card. Problem kind of solved.

Have you tried running in safe mode?

Yep - made issue worse - it reset about every 15 minutes even with no provocation.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20211104183020.zip (502.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
1.7.2 (i want to go back to 1.7.1), no idea what octopI version, fw is marlin 2091 and i made many numeric changes to cfg files, browser chrome, windows 10"pro", the pi was put on the Raspi 4 with genuine PSU a few months ago, in octoprint I made much use of USB keyboard but kept plugins down to a few. I just added a new E stepper, a bigass 4248 and I am allotting it 1450ma. It's running spreadCycle and rest of steppers on stealth. Linear advance used, umm. Oh I got a camera on it, i made sure I got connections on good then used sticky ass masking tape for good measure. (not wimpy true masking tape, this thing will pull hairs) and camera serves out to blueIris 4 on my PC. Still streaming - nice.

Did I mention it did a fantastic job on 7 good prints before it shit the bed?

I am feeling heavily this is HW, now that it got worse in safe mode - in fact it rebooted into it again because of "error loading/booting/starting" i forget words. It failed to load so reloaded into safe mode a few times, now it did it again and it's running plugs ok but it'll reset by time I'm done with this.

Do you have a touchscreen or a similar 3rd party client connected?

Your log is partly filled with entries ~each second from something requesting the API. Not sure if it's related but it has filled the logs with warnings.

The system info bundle that's there doesn't show OctoPrint (re)starting at any point - presumably you did the testing yesterday? And then the log rolled over.

I would try disabling as much as possible. Run in safe mode (you've got some errors from OctoText as well) and disconnect any 3rd part device - Slicer connections, smartphone apps, touchscreen UI (OctoDash/OctoScreen etc).

I don't get much feeling from the log, the only feeling I have is that it might end up being overloaded. A log of when it actually restarted OctoPrint might help with that - you should be able to see this as octoprint.log.DATE in the logging download.

Charlie hi and thanks
I don't have a touchscreen attached, just the raspicam or whatever and it is running very stably.
Sadly when I went to safe mode, it seems to reset even more from every 15mins to every 12 hours in exteremis.
I did pop the SD card in windows box and it said it had errors, after this I haven;t tested it much. I'll test it more. I would rather not get another berry.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.