Octoprint resets my bed leveling

#1

What is the problem?
When I try to start a print octoprint will ignore the bed leveling I have done earlier and will run the nozzle into the bed. I have tried seting the bed leveling to the top that marlin can go (2mm) to see if octoprint will ignore it. It did and it sent my nozzle right into the bed. If I print from an sd card the printer runs fine.
In short octoprint is sending my nozzle into my bed.

What did you already try to solve it?
I have re-installed octoprint other than that not much.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
I am running the newest version of OctoPrint not OctoPi. I am using a raspberry pi 3B. My printer is the anet a8 with many safty upgrades and I am using marlin.

#2

Hello @William_Rice,

do yo use the printers bed leveling system or a OctoPrint plugin?
Do you have a start GCODE script in OctoPrint and if yes, how does it look?
What Z sensor do you have?
When you give the command to home Z and the nozzle crashes into the print bed, then there is something wrong with the printer settings.
Also OctoPrint does not know, what settings you perform with your printer firmware.

#3

I use marlin's manual bed leveling, but I do have a auto bed leveler that I have not setup yet. I do not have any start or end GCODE commands, I use cura if that helps in any way. I have a small switch at bed level next to one of the z motors I dont know the name of it.

how do i get the .log files or the output on terminal tab?

#4

Here is a hint how to find the logs:


The small switch is actually called Z axes home switch.

With a correct leveled hot bed, the nozzle can't crash into the bed.

1 Like