Octoprint running on latest nightly OctoPi not connecting to printer


#1

What is the problem?
I installed 2018-04-11_2018-03-13-octopi-stretch-lite-0.15.0.zip

WiFi works, but I can't connect to my CR-10S.

When I try to connect to my new CR-10S, I get the following error:

Error reported by printer
Your printer's firmware reported an error. Due to that OctoPrint will disconnect. Reported error: MINTEMP triggered, system stopped! Heater_ID: 0

What did you already try to solve it?
Rebooted etc.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

That's your printer saying it's not able to function because something's up with your temperature sensor. Fix the underlying hardware problem.


#3

The printer is currently printing a job fine via SD card... The control panel is displaying the correct temperature (tested with a thermometer).

Could it be something else?

Should the auto settings work or is there something else I need to do?


#4

I'll just repeat what I already wrote in the OctoPi ticket:

This is your firmware reporting a serious error. I have no idea why it works when you print from SD and not via serial, but in any case, this is not something that OctoPrint (or OctoPi) can solve. If your firmware reports catastrophic heater failures on the serial interface, it's not possible to use that interface. Figure out why your printer does that and fix the underlying issue.

I don't understand the question. What auto settings?


#5

Hi,

had the same here.
image

I noticed this happened reproducible when USB is connected first, then power switched on on the printer. But after Update 1.3.8 of Octoprint I got this error message once and then the next try it suddenly connected?!
I'll keep watching.

Using OctoPi 0.15 nightly (about 2 weeks old) but now updated with 1.3.8 and apt-get update/apt-get upgrade.


#6

This is a message sent by the firmware. Unless there's a firmware bug that causes it to generate this message on some messages received on the serial bus (which should never happen) this is completely unrelated and out of control of OctoPrint.


#7

Solution? Firmware-Update? (It's a CR-10S, 1 month old)

The bad is, last time I wanted to stop the print, but due to unable to connect, I was unable to stop.


#8

To quote myself from a couple of posts up in this topic:

Might be a wiggling thermistor, might be a firmware issue. I can't tell you. But it's definitely your firmware saying that something is seriously wrong. Anything prefixed with a Recv: in the terminal tab comes from your firmware, and if that starts with Error: it's some kind of error that your firmware detected and reported. And temperature issues are so fatal that the firmware usually also switches to "kill" state, meaning even if that error where ignored by the host, it would no longer react to serial.


#9

I refreshed my firmware with Marlin and that solved the issue. Apparently there is some bug in the firmware with some CR-10s. Now it's working like a charm!

Thanks for all your help.


#10

Updating firmware to Marlin worked for me.


#11

I'm experiencing the same issue on my CR-10S. Thanks for the feedback on the Firmware, however do we know what in the firmware is doing this?