Octoprint running really slow

What is the problem?
Octoprint interface is really slow. I open a new window and it works for maybe a minute, then it gets really slow, won't load anything, etc. When I refresh the page from that state, it says "loading failed: socket connection failed..." Opening a new tab will allow it to load, but refreshing the page does not.

What did you already try to solve it?
I am stuck on what to do. I haven't had this issue before.

Logs (syslog, dmesg, ... no logs, no support)
octolog.log (122.9 KB)
Attached is my octoprint log.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
I'm running Octopi on a Pi 3 Model B Rev 1.2, and the firmware version is 1.4.0. Trying to connect from my computer running chrome.

I have similar issues. After some time running really smoothly all my octoprint Installations on different Pi are really slowly now. On one (Pi 4) it is not even booting up anymore. Version 1.5.3

The remaining one - slow but at least working:

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.3 Safari/605.1.15
connectivity.connection_check: 8.8.8.8:53
connectivity.connection_ok: true
connectivity.enabled: false
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 917016576
env.os.bits: 32
env.os.id: linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.3
printer.firmware: Marlin 1.1.0-RC8 (Github)

Try safe mode to rule out a plugin causing issues.

Hello!
I had the same problem. After a while the web interface starts getting sluggish up to a point that is unusable. In my case the culprit was the Printer Notifications windows. Pressing the 'clear notifications' button restored the usability for a while.
image

I finally disabled the panel completely, it can be done from the settings / printer notifications, uncheck the "enable" box.

I hope it helps, cheers
ML

5 Likes

Just found this answer, mlutteral.
Thank you.