Octoprint says no serial port available

What is the problem?

Octoprint shows this message:
No serial port found, are you sure your printer is physically connected and supported? Try [refreshing](javascript:void(0)) and if that doesn't help please see the FAQ.

What did you already try to solve it?

Turned octoprint off and on...several times. Sometimes it would start and run normally for a few minutes then shut down again saying there was no serial port again

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20240507075909.zip (72.3 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.10.0 Pi VErsion 1.8.5, Ender3v2/Sprite extruder, [Ender3V2-427-BLTUBL-MPC-20240125.bin] running PETG at 240/70

Have you tried different USB cables to connect the printer? Did you try anything from the FAQ linked?

I may have discovered the cause. The connection from the pi to the printer was a little sketchy. I made sure that it was secure and printed in pla as a first test. When that comes out I'll try another
petg in case heating was the issue. So far it's been happy for the last 2 hours and 2 more to go. So it looks very promising
Thanks all

1 Like

I wonder if it's possible to create a "serial port stress test" that sends a battery of commands and verifies the results. I don't know if plugins can feed serial data fast enough.