Octoprint sending start command and making print fail

What is the problem?
Octoprint is sending out a gcode command to start the printer right before the mmu2 unit is supposed to load the filament. This is causing the printer to restart and the print to fail.

What did you already try to solve it?
I updated prusa and mmu firmware, had a long conversation with prusa support, tried printing directly from printer sd card (and it worked thus octoprint is definitely the issue), tried restarting, tried factory reset on printer and mmu2, tried changing slicer settings to many different combinations

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Send: N35 G1 X240.0 E25.0 F2200.074
Recv: ok
Send: N36 G1 Y-2.0 F1000.0
28
Recv: ok
Send: N37 G1 X55.0 E25 F1400.0101
Recv: fsensor_stop_and_save_print
Recv: echo:Enqueing to the front: "PRUSA fsensor_recover"
Recv: echo: 3.8.1-2869
Recv: echo: Last Updated: Oct 24 2019 17:11:58 | Author: (none, default config)
Recv: Compiled: Oct 24 2019
Recv: echo: Free Memory: 2123 PlannerBufferBytes: 1392
Recv: echo:Hardcoded Default Settings Loaded
Recv: adc_init
Recv: CrashDetect ENABLED!
Recv: FSensor ENABLED
Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
Send: N38 M105
28
Recv: echo:SD card ok
Recv: Error:Line Number is not Last Line Number+1, Last Line: 0
Recv: Resend: 1
Recv: ok
Send: N1 M73 P0 R19525
Recv: NORMAL MODE: Percent done: 0; print time remaining in mins: 195
Recv: SILENT MODE: Percent done: 255; print time remaining in mins: -1
Recv: ok
Send: N2 M73 Q0 S200
21
Recv: NORMAL MODE: Percent done: 0; print time remaining in mins: 195
Recv: SILENT MODE: Percent done: 0; print time remaining in mins: 200
Recv: ok
Send: N3 M201 X1000 Y1000 Z1000 E8000*52
Recv: ok

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
octoprint 1.3.12, octopi 0.16, prusa mk3s with mmu2s with latest firmware.

RESOLVED
Found this since posting:

1 Like