Octoprint server "crashes" when print job starts

What is the problem?

Starting a print causes octoprint to say: The OctoPrint server is currently not running

What did you already try to solve it?

Tried to load a backup, it worked but the problem still persists

Have you tried running in safe mode?

Unable to, the server crashes before I can even access the UI

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20230310101931.zip (1.1 MB)

Additional information about your setup

Ender 3 V2, Raspberry PI 3B+

Hello @MeeM_Kade !

First, your Pi suffers from overheating:

2023-03-09 20:11:16,290 - octoprint.environment - INFO - Detected environment is Python 3.7.3 under Linux (linux). Details:
|  hardware:
|    cores: 4
|    freq: 1400.0
|    ram: 914006016
|  os:
|    bits: 32
|    id: linux
|    platform: linux
|  plugins:
|    pi_support:
|      model: Raspberry Pi 3 Model B Plus Rev 1.3
|      octopi_version: 0.18.0
|      octopiuptodate_build: 0.18.0-1.8.6-20221018093204
|      throttle_check_enabled: true
|      throttle_check_functional: true
|      throttle_state: '0x80008'
|  python:
|    pip: 20.3.3
|    version: 3.7.3
|    virtualenv: /home/pi/oprint


There is an issue withe Bed thermistor. It stays at 0.00 Β°C. Therefor the firmware reports an Error.

2023-03-09 20:30:17,155 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: !! STOP called because of BLTouch error - restart with M999
| Last lines in terminal:
| Recv:  T:220.00 /220.00 B:27.24 /0.00 @:94 B@:0
| Recv:  T:220.00 /220.00 B:27.24 /0.00 @:93 B@:0
| Recv:  T:220.02 /220.00 B:27.23 /0.00 @:93 B@:0
| Recv:  T:220.00 /220.00 B:27.23 /0.00 @:94 B@:0
| Recv:  T:219.97 /220.00 B:27.23 /0.00 @:94 B@:0
| Recv:  T:220.02 /220.00 B:27.24 /0.00 @:93 B@:0
| Recv:  T:220.04 /220.00 B:27.24 /0.00 @:92 B@:0
| Recv:  T:220.04 /220.00 B:27.23 /0.00 @:92 B@:0
| Recv:  T:220.04 /220.00 B:27.27 /0.00 @:91 B@:0
| Recv:  T:219.92 /220.00 B:27.26 /0.00 @:96 B@:0
| Recv:  T:219.97 /220.00 B:27.26 /0.00 @:94 B@:0
| Recv:  T:220.00 /220.00 B:27.29 /0.00 @:93 B@:0
| Recv:  T:220.00 /220.00 B:27.27 /0.00 @:94 B@:0
| Recv:  T:219.97 /220.00 B:27.29 /0.00 @:95 B@:0
| Recv:  T:220.02 /220.00 B:27.27 /0.00 @:93 B@:0
| Recv:  T:220.00 /220.00 B:27.26 /0.00 @:94 B@:0
| Recv:  T:220.04 /220.00 B:27.33 /0.00 @:92 B@:0
| Recv:  T:220.00 /220.00 B:27.27 /0.00 @:94 B@:0
| Recv:  T:220.00 /220.00 B:27.32 /0.00 @:94 B@:0
| Recv: Error:!! STOP called because of BLTouch error - restart with M999

There is als an BLtouch error:

| Recv: Error:!! STOP called because of BLTouch error - restart with M999
| Recv: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

There error during reading the serial port:

2023-03-10 08:09:24,686 - octoprint.util.comm - ERROR - Unexpected error while reading from serial port
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/comm.py", line 3997, in _readline
    ret = self._serial.readline()
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/comm.py", line 6672, in readline
    c = self.read(1)
  File "/home/pi/oprint/lib/python3.7/site-packages/serial/serialposix.py", line 596, in read
    'device reports readiness to read but returned no data '
serial.serialutil.SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)
2023-03-10 08:09:24,725 - octoprint.util.comm - ERROR - Please see https://faq.octoprint.org/serialerror for possible reasons of this.

How did you get the systeminfo bundle?

Guess ill have to get a better case for the pi, but hows the bed therm not working? it says its at 27 C. I also got the systeminfobundle before the ui crashed. Sometimes it lets me access it and sometimes it dosent, whenever i try to get to the reboot into safe mode option, it dosent work. I was only able to get the systeminfo bundle.

1 Like

I've overlooked the log again and you can discard my mention about the heated bed.

1 Like

So what do i do about the M999 error and the server crashing?

BLTouch errors are usually caused by loose or noisy connections (ie. check all the wiring, move it away from electrical noise such as motors), or by the bed being too un-level whilst probing. You should probably watch the printer to see if you can figure out where the BLTouch error is coming from - if it always happens when probing at the same place for example.

In the logs there is no indication of the server crashing, it looks to shutdown & restart normally. I would try safe mode, you can do it via SSH if the UI is unavailable - the link shows you how. It could be that you have a plugin triggering a shutdown.

I checked the connections and it looks fine to me, but how can I find the plugin that's causing this? I have more than 5 and I don't want to scrape through each one

Have you tried it in safe mode and the issue disappears then?

I actually was able to get into safe mode earlier, and it seemed to not crash.
(earlier it would crash as soon as the server started but I was able to get in before it had the chance to)

One way you can reduce the number of plugins you need to test is by disabling half of them, testing, then either enabling/disabling another half each time and you can locate the problem plugin efficiently. There's no indication in the log of why it is shutting down, only that it is doing so.

Ok, ill try to do that and see if it works

i just noticed this, could this be an issue?

So far it seems like the plugin octoeverywhere crashes my octoprint, what should i do to fix it?

While it is unlikely that the firmware on the printer would cause the OctoPrint server to crash, the onus is on you to determine if the firmware version is causing you problems.

Since the build date is almost one and a half years ago, I'm guessing there are more up-to-date versions available for the Creality Ender 3 V2. Be aware that some of Creality's firmware has "challenges" that may be worse than what you are running now.

The thing is that im actually using jyres firmware, a modded version of crealitys, i wasnt able to run crealitys OG firmware because it made my printer crash as soon as i did anything level related on it, so i used jyres instead

Disable or remove OctoEverywhere if it is causing problems. Once you get a stable system, you can figure out how to add back the functionality that plugin provides. I'd open an issue on the plugin's website. I see on that site that the newest release was yesterday (10 Mar 2023).

I can't give you any advice on firmware for Creality's printers as I don't (and won't) own one. All I can suggest is that whatever firmware you use, understand where it comes from and how it is supported. If the firmware you are currently uses has a web site or a project page then check there to see if what you have is the latest and greatest.

Seems that octoeverywhere was the issue, ive contacted the dev to ask him how I can fix this. One thing I now have is octoprint telling me that octolapse didn't capture any frames, I guess ill need to figure that out

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.