Octoprint server critical shutdown


#1

What is the problem?
The octoprint Server crashed after working on the "System Command Editor" plugin.
I tried to add some commands into the "System Command Editor" plugin, but it didn´t work. After a reboot of octoprint, the new commands where gone. I tried this several times and during one of the reboots, the server crashed and is not running any more.
The webgui is shown that:

What did you already try to solve it?
The ssh-login is still working, so I tried to verify that the process is running (as requested in the picture above):
There is no python process showing up.

I checked the octoprint.log and found the following line:
"octoprint.server - CRITICAL - Now that is embarrassing... Something really really went wrong here. Please report this including the stacktrace below in OctoPrint's bugtracker. Thanks!
2018-10-24 14:07:37,711 - octoprint.server - ERROR - Stacktrace follows:"
The octoprint.log ist attached.

I tried a reboot of octoprint and a reboot of the RasPi - both did not help. I am not able to get the octoprint-server running again.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

I´m am running
Octoprint Version: 1.3.9
OctoPi Version: 0.15.1

on RasPi 3 B+

Has anyone an idea, what´s going on?
thanks in advance,
matze

octoprint.log (10.7 KB)


#2

Looks like you'll want to go visit your ~/.octoprint/config.yaml file. Yaml files are touchy about formatting and it's likely that something isn't happy. Take a look and see if anything is obvious in the area of indenting.


#3

thanks for your help!
I checked the config.yaml file and couldn´t find an obvious indenting-failure. But I am not an expert in this ...
Is there an original config.yaml that i could download and replace my one?


#4

I've not been able to find it by searching either the OctoPrint or Octopi repositories. So I've edited one of mine but I'm not sure if it's 100%; it is likely missing the commands in the System pull-down menu.

config.yaml (854 Bytes)

You should save your existing version, review the API key and copy it over to this one. You should also review this section:

server:
  commands:
    systemShutdownCommand: sudo shutdown -h now

If yours had more entries there under "commands:" then consider bringing those over into the new file. You could always reference your own version and use it to compare things.


#5

it worked, great !!

First I tried to put some parts of your config.yaml into my file, but it didn´t work. So obviously I had some bigger issues with this file. So I took your file and added my specific Informations. This works fine (-:

I had some trouble configuring the "System Command Editor". I tried to switch the webcam on and off by adding some commands into this plugin. I didn´t get it done, so I tried to configure the config.yaml manually by using nano on the raspi. Obviously I messed something here.

@ OutsourcedGuru:
Thank you so much for your help!!

Matze