Octoprint server doesn't start


#1

What is the problem?
Octoprint server doesn't start. Raspberry is connected to the network but if I go on the page where I could control the printer there is the message "The OctoPrint server is currently not running" with the suggestions.
I used to unplug the raspberry after every print, I didn't know that was better shutdown the server before because until today evertything worked great.

What did you already try to solve it?
I opened the log file but I don't understand the problem. There are many "null" (only opening the file with notepad++) that I think are the problem but I don't know how to solve.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
I think that the only information needed is the log file, if not I'll give you other informations.
octoprint.log (69.5 KB)

Thanks in advance.


#2

You did try to Refresh/Reload your browser, right?

You've got a lot going on in your log file.

  • Occasional under-voltage
  • Way too many logging events for backoff related to your webcam
  • A lot of warnings in the IPv6 space for tornado not being able to pull cached images
  • An indication that your Pi is throttled due to under-voltage

Rule out all the added plugins by running in Safe Mode and see if the problem goes away.


#3

Yes I tried to refresh obviously. My supplier for raspberry is 5 Volt 2.1 Ampere and the webcam is temporarily not plugged,

Before you replied I tried to connect the raspberry to another network so I modified the file octopi-wpa-supplicant.txt in the sd with my values but nothing happened (it was visible in the network but the server didn't start).
I read your suggestion so I tried to connect it to internet to access by SSH but it wasn't recognized so I put sd in pc and I read a message that it wasn't readable so I needed to repair the sd. After I done it, the file octopi-wpa-supplicant.txt was gone and I think other files too.
I don't know what happened but I'm scared I have to starting over on with octoprint losing all my plugins and settings.


#4

The specification for a Raspberry Pi 3B is 5V @ 2.5A so your power adapter should be replaced. Note that your webcam will also draw additional power as well as other things you plug into the USB ports later. You might as well fix this early.

I think you're about the third person today whose Windows prompted them to format a perfectly-good ext4 partition.

Start over.

Never format your microSD. Just follow the instructions on the OctoPi page.

Feel free to refer to this after you've used Etcher to flash the downloaded zip file straight to the microSD.


#5

I want to underline that!


#6

don't EVER just disconnect or turn off power to the pi. it corrupts files on the sd card. you have to run the shutdown from the octoprint web interface, or ssh in and run "sudo shutdown -h now" then unplug power after you give it a minute or so to perform it's shutdown.


#7

There's also sudo poweroff which wins the least-characters contest.