Octoprint server is currently not running (but it is)


#1

What is the problem?

Web access periodically fails with "Octoprint server is currently not running" message.

What did you already try to solve it?

Logged in and checked the process: running fine.
Checked octoprint.log: no error messages, last line is a heartbeat check
Restarted server with sudo service octoprint restart, and then was able to bring up web page again.
After restarting, generally able to bring up Octoprint for a day or two before the error message returns

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Operating inside corporate intranet
No connection to a time server, so the pi thinks it's back in August
All plugins installed manually, as no direct connection to internet available

| hardware:
| cores: 4
| freq: 900.0
| ram: 918200320
| os:
| id: linux
| platform: linux2
| plugins:
| octopi_support:
| model: 2B
| revision: a01041
| version: 0.15.1
| python:
| pip: 10.0.1
| version: 2.7.13
| virtualenv: /home/pi/oprint


#2

Still getting this on multiple Raspberry Pis. Thought this could be related to DNS address resets, but now have them on fixed IPs. Last one I checked had a status message in the log from only a minute or two before: octoprint.plugins.navbartemp - INFO - Checking SoC internal temperature. Again, the suggested ps -ef shows octoprint still running. Nothing looks strange in the log file. Octoprint version is 1.3.8. Restarting with sudo service octoprint restart works fine. Just frustrating that I have to go in and manually do this every so often. Haven't had this cause a failed print yet.


#3

This may not be related, but I have experience problems reopening the browser interface via my macbook. The octoprint pi is clearly running as I can see activity via the pi's LED's but the interface will not open or will only partially open (i.e. no css). Last night when I could not gain access to octoprint, I turned off the macbook's wifi and then turned it on again, Voila! complete and instant access. Oh, and I have the pi on a fixed ip.

Jd


#4

Bingo.. this fixed it for me.. I love you man..