OctoPrint server is currently not running, error comes back after re-install

What is the problem?
The OctoPrint server is currently not running -- I am unable to access my OctoPrint vi web console

What did you already try to solve it?
I updated my RaspberryPi System files, I reinstalled OctoPrint via SSH, it worked for a couple of days and then went back to this same error.

Logs (syslog, dmesg, ... no logs, no support)
OctoPrintLogs.zip (49.2 KB)

The above logs are all I could get mannually via WinSCP, I could not even access the RECOVERY page of my OctoPrint web UI.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

Connecting to a RaspberryPI3 from a windows machine via Wifi. Runs a Prusa i3 MK3.

If anyone could point me in the right direction in the logs it would be appreciated.

I guess it's a failing sd card

Nooooo, that would suck.

I just replaced it a month ago because my previous one died.

The only other explanations I got are

  1. insufficient power - but it doesn't report that in the logs so it should be fine
  2. you don't shut down the pi properly and pull the plug instead, which can cause file system corruptions.

I also replaced the power supply a couple of months back, I had the low power warnings before that.

I always use the the drop down menu inside the OctoPi web interface to shutdown the system.

Is there any additional logging I can switch on after I re-install the system?

Thanks for your help, looking at my logs.

That's all you can do :+1:

Not really. the additional logging is just to debug issues with the connection to your printer or with a particular plugin.

No problem.
I hope the next sd card works forever :crossed_fingers:
You may want to look into industrial rated cards - they're supposed to have a longer live expectancy.