OctoPrint server is currently not running


#1

What is the problem? I get the error message octoprint server is currently not running.

What did you already try to solve it? I tried the suggested commands

  1. I checked the processes by running ps -ef | grep iI octoprint | grep -i python.
    It just responds with pi@octopi:~$ nothing else.
    but if I run the commands separate ps -ef | grep -i octoprint I get

pi 9362 724 0 17:32 tty1 00:00:00 grep --color-auto -I octoprint

and/or ps -ef | grep -i octoprint
It responds with;
pi 10048 724 0 17:325 tty1 00:00:00 grep --color-auto -I python

(hopefully I wrote that correct as the Octoprint is on another monitor and I can't copy from it)

  1. ~/.octoprint/logs/octoprint.log I just get No such file or directory.
    Using cd /home, cd/pi, cd/OctoPrint, ls, there is only a readme.txt file (I can't figure out how to read it) there is no octoprint.log or logs directory.

  2. type in sudo service octoprint restart. and just get the cursor back at the current directory.
    I have restarted several times (sudo reboot), waited hours – still not ‘running’.

  3. I have 'reloaded' the octoprint.img file and updated the wifi and country info. (using Samsung 16G microSD card – just purchased). Restarted the Raspberry pi. Went to my browser and typed in the access http://10.0.0.15 as it says in the Pi monitor. (http://octopi.local not working).
    And I end up with the same ‘octoprint server is currently not running’ page with the ‘check these items’ page.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

OctoPrint version : 1.3.8
OctoPi version : 0.15.1
3d Printer not connected at this point (doesn’t change when I do)
I’m running Window 10. (current) with firefox and/or Microsoft edge browsers – same problem on both.
There is no octoprint.log as mentioned above.

What can I try next? Hope I gave enough information.


#2

Invalid network address for subnet 255.255.255.0

The first thing I see is a questionable IP network range. If your netmask is 24 (255.255.255.0) then your home's router is setup incorrectly. If your netmask is 8 (255.0.0.0) then this is okay, though.

Assuming a netmask of 24, though, start at the router and issue 10.1.1.1/24 to the router's internal network. Everything then should be re-issued IP addresses now in the 10.1.1.0/24 network which is a valid network address.

Multiple printers on a single Raspberry

Personally, the max printers that I'd put on a single Raspberry is one.

Microsoft doesn't have Bonjour name resolution support out-of-the-box

For a Microsoft Windows workstation to be able to turn "octopi.local" into an IP address, you'd either need to install iTunes or to follow other advice.

Install per the instructions

I'm not sure but I'm guessing that you're attempting to get this going having not followed the instructions to use Etcher.


#3

do this:
ls -l ~/.octoprint

Note if you do ls in your home directory it won't show the "hidden" .octoprint directory.


#4

am I missing a config file or something? I don't see how you are intuiting this.


#5

Invalid network address? mine is 10.0.0.15. I can even see it on the router setup. (router is at 10.0.0.1) So I'm thinking it is ok.
There is only one printer on it. And disconnected it does the same thing.
The octopi.local might not be a big thing as I can 'connect' with the http://10.0.0.15 (or whatever it says). If it is off, the same address gives an error of not finding that address.
I used win32diskimager not Etcher. Etcher kept giving errors in the end. not sure why - and I didn't research it further. The win32diskimager took about 20 - 30 mins to make the disk.


#6

after typing ls -1 ~/octoprint , I get config.yaml (not sure if the last letter is a 1 or L) Is this the error file?


#7

last is a lowercase L. But that kinda works. Still, I see you are doing ~/octoprint and I asked for ~/.octoprint .. note the period after the slash.

There should be many other files/directories in there: data, logs, config.yaml, and so on.


#8

I just retyped it wrong in this help area. I did have ls -1 ~/.octoprint as you said. Still only getting config.yaml
I got the octoprint from OctoPrint.org - Download & Setup OctoPrint. did I miss something else?
I'm not familiar with this operating system - and can look up just enough to be dangerous.


#9

What image did you use with win32diskimager?


#10

2018-04-18-octopi-stretch-lite-0.15.1.img

Just noticed, on startup everything shows ok except this line
[FAILED] Failed to start resize2fx_once.service'
See 'systemctl status resize2fs_once.service' for details.
Not sure how to check this. Maybe the problem?

and another thing, I only get the 10.0.0.15 if connected with ethernet cable. wifi not connecting?


#11

Good, you are going from octopi. Get it working with ethernet, then worry about wifi. One less variable.

resize2fs is something that happens on first boot. probably other errors; what happens when you run that systemctl command?

If you have it on xx.15 you should be able to ssh to it (putty, if you're on windows), which will make pasting logs easier.


#12

It's rare when an enduser actually issues 10.0.0.0/8 as a Class A network. They usually have some experience with /24 (Class C), they hear that 10.0.0.0 is a private collection of addresses and then they choose to use it... incorrectly in some cases.

It's not valid to choose a /24 (255.255.255.0) netmask and then issue their wi-fi router's private address as 10.0.0.1/24. It's just wrong. (It would be okay with a /8 but not with a /24.)

For most new people, they should start with 10.1.1.1/24 at the router and let the chips fall where they may since this is the easiest to remember. Technically speaking, the first network address should be 10.0.1.1/24 for the router, however. If you attempt to bind 10.0.0.1/24 to your router, downstream computers won't be able to properly route packets.

I've been arguing this same issue on another thread here, for what it's worth.


#13

But the OP doesn't even mention that. It appears they are using 10.0.0.0/24, which is entirely valid unless you are on a huge network.


#14

I guessed this from his IP address. In my humble opinion, he's going to continue to have problems until he re-issues a different network address on his router. I'd suggest 10.10.10.0/24 which is easy to remember.


#15

Ok, I have gotten putty working and connected to the pi using ethernet. (thanks I can now copy easier!)
Now after typing ls -l ~/.octoprint this is what I get.

total 4
-rw-r--r-- 1 pi pi 383 Feb 22  2018 config.yaml

and when I type the following; (I'm hoping the is formatted correctly/better for the help page)

pi@octopi:~ $ ~/.octoprint/logs/octoprint.log
-bash: /home/pi/.octoprint/logs/octoprint.log: No such file or directory

New update: I have 'reflashed' another micro sd card. and I am now getting wifi and ethernet showing on my router 'connected devices' page. The wifi is showing at 10.0.0.14 while the ethernet at 10.0.0.15.
both browser pages show ' The OctoPrint server is currently not running'. I still get the same results when typing the 'help' suggestions (listed above results).
As far as the router connections and addresses you are both way above me in understanding. When I check the wifi connection on my ipod touch it does show IP address 10.0.0.10 subnet mask 255.255.255.0 Router 10.0.0.1.
Not sure if this is good or bad. I've never had problems connecting anything before. Should it be changed?

Would it help if I did the following as on the pi monitor? just to see if octoprint can run?


This image comes without a desktop environment installed because it's not
required for running OctoPrint. If you want a desktop environment you can
install it via

    sudo /home/pi/scripts/install-desktop


#16

You don't need to run it with a monitor since you can connect to it remotely.

Try sudo service octoprint start, then look for that log file.


#17

After may hours, I used another computer (laptop) still windows 10, redownloaded and made a new boot disk using etcher. Still got the error after it finished the disk but It finally worked and I am able to see octoprint thru ethernet connection.
Now to fix the other problems.....
Thanks for your help.


#18

What was the etcher error?


#19

Just guessing, but "the error" could be—if the Auto-unmount-on-success option wasn't checked—that Windows failed in its attempt to mount the ext4 second partition (to be expected).