OctoPrint Server not running after install - No log folder

What is the problem?

I cannot start octopi after installing. I am able to SSH into the Raspberry Pi and run commands. When I check for the logs, I cannot find the file or directory.

What did you already try to solve it?

I have installed Octoprint using the Raspberry Pi Imager tool. I tested on a new Raspberry Pi 4B and my old Raspberry Pi 3B+. I tested on a new 32GB SD and an old 32GB SD. I have tried restarting the service and I have tried restarting in safe mode.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

I do not see a way to pull this via SSH.

Additional information about your setup

This is the extent of the log I am able to get. There is no log folder and I am unsure about any next step.

Linux octopi 5.10.63-v7+ #1496 SMP Wed Dec 1 15:58:11 GMT 2021 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
-bash: /home/pi/scripts/welcome: No such file or directory
cmanske@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
cmanske@octopi:~ $ cd ~/.octoprint
cmanske@octopi:~/.octoprint $ ls -l
total 4
-rw-r--r-- 1 cmanske cmanske 356 Jan 11  2021 config.yaml
cmanske@octopi:~/.octoprint $ cd logs
-bash: cd: logs: No such file or directory
cmanske@octopi:~/.octoprint $ ls -a
.  ..  config.yaml
cmanske@octopi:~/.octoprint $

What do you get from
sudo ls -l /home/pi/.octoprint/ ?

Did you change the username when you flashed it in the imager? Definitely do not do that.

1 Like
cmanske@octopi:~/.octoprint $ sudo ls -l /home/pi/.octoprint/
[sudo] password for cmanske:
ls: cannot access '/home/pi/.octoprint/': No such file or directory

I didn't know we weren't supposed to do that. Let me re-flash and test with the default username.

1 Like

It says on https://octoprint.org/download:

If you've followed an (official) guide elsewhere that needs updating please let us know.

These screenshots look familiar. There's a fair chance I was not paying attention, but if I find the guide without these instructions I'll forward them to you.

I appreciate your help.

Been sitting here for hours trying to figure this out... Why is there an option to silently and unintuitively brick the install?

Changing the user is a new option that was recently added to the Raspberry Pi Imager.

That imager is maintained by Raspberry Pi, not OctoPrint. And that's a valid option when used with other images, such as a base image of Raspberry Pi OS itself.

just saved me from another half an hour of frustration. thanks!
I have watched the official configuration video from the octoprint main page. should be mentioned IMHO.

The video was made before the option was added to the image, and by Thomas Sanladerer, not us so it is hard to add in the extra detail from our side.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.