Octoprint server not running after plugin install failure

What is the problem?

after tryind to install the plugin flowspeedrename, my server isn't running

What did you already try to solve it?

tried apt-get update/upgrade, then it starts once in safe mode but after still have the message that server isnt running

Have you tried running in safe mode and if so did it solve the issue?

i don't know how to force safe mode from ssh

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

dont know where to fing the logs

Additional information about your setup

all updates done

Hint: logs, linked in blue heads to an FAQ entry of how to find the logs. That would help massively to find out the root of the issue.

  • on Windows: %APPDATA%\OctoPrint\logs
    i dont find this folder

i dont understand how to get it via ssh

octoprint.log (45.4 KB)

1 Like

i finally find a solution to get the log directly from sd, hope it can help

1 Like

One of the plugins you have is blocking server startup.

Whatever you did with this, has broken. This line:

| !setup = /home/pi/.octoprint/plugins/setup.py

Should not exist, and is breaking the server.

To fix, via SSH:
rm ~/.octoprint/plugins/setup.py
sudo service octoprint restart

Let me know if you have more problems.

yes problem appears after this plugin installation
i tried your solution and i have rm: cannot remove '/home/pi/.octoprint/plugins/setup.py': No such file or directory
it is possible to fix it directly on the sd card?

i only have this file in this directory. should i delete it?

Try deleting it, that is compiled Python code that may still be causing issues.

YESSSS it worked!!!!
thank you very very much you're my hero!
i escape from a clean install...

can you explain me why this plugin installation failed? it was not a plugin from the repository i installed it with the from uploaded file button

1 Like

Great news.
So it seems OctoPrint thought that it was a single file plugin and put just the setup.py, rather than the full package. Have you got a link to the plugin in question?

i tried to reinstall it and it worked well.... that a mystery... but i didn't understand how the plugin works so il delete it

I don't know what went wrong here on install either, but I've just pushed a commit that will make sure only such files are actually loaded that look like plugins (= any of the defined control properties are detected in the file's AST). Will be shipped with OctoPrint 1.6.0 (NOT 1.5.0 which just entered RC phase yesterday).

nice! now if i have the same problem i know what i have to do