OctoPrint server not running - Failed update >>1.9 - Can't import 'safe_str_cmp'

I recently attempted to update OctoPrint to version 1.9 via the web server of OctoPi. The version is currently at 1.8.7 and I was attempting to update to 1.9.

During the installation I briefly noticed error which caused failure of the update. Unfortunately I don't remember the exact error. Maybe compatibility and failed installation due to it. Either way I attempted to to connect via the web to OctoPI and was greeted with an error stating " The OctoPrint server is currently not running".

Not being a Linux guru I have looked at the logs and done my best researching on the internet the errors I can somewhat make out in the log. It seems to be related to an issue with Werkzeug. It fails to import the "safe_str_cmp" from "werkzeug.security". Looking thru the net I have seen examples of trying to force re-install the OctoPrint 1.8.7, which I have successfully done. I have tried updating and downgrading Flask / Werkzeug. The install command responses in the terminal seemed normal for both installations. Neither of theses processes have changed the outcome of the log in regards to the 'safe_str_cmp" import error. I still cannot access the server with the web and receive the same error screen attempting to do so.

A version query of the Flask reveals the following versions installed:
Python 3.7.3
Flash 2.1.0
Werkzeug 2.0.0

** I am trying to submit a Systeminfo Bundle but am lost how to do it. When I initiate the "octoprint systeminfo" in the terminal of raspberry pi, I only get a long pause and a return back to the terminal prompt. No file is saved that I can find and there is no text details either. If this is needed can you please give me further help on this? ** Thanks!

I have provided uploaded my log file.

octoprint.log (102.7 KB)

I solved this by force installing the latest version thru the terminal. Apparently something was a no go with 1.8.7 and I had to attempt the install of 1.9 again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.