Octoprint server not starting on boot

What is the problem?

I'm trying to connect to my octoprint server but I keep seeing the message that states that the Octoprint server is not running, despite having the pi on for more than 30 mins

What did you already try to solve it?

I tried running the octopi stable image rather than the new camera stack image and that seems to work but I can't get the pi camera to work with that image.

I SSHed into the pi and tried running the commands suggested on the "Octoprint is currently not running" page and didn't see any python processes running. There is no log file either. Restarting through ssh did not work

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Can't get into the server


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Octoprint version 1.9.2
Octopi version 1.0.0
printer: Ender 3 v2
Firmware: 1.0.4 (I got this off creality's site yesterday)
PuTTY to use SSH

You are probably trying to change the user name and are running into

I'd already have that fixed if I wasn't running into some other issues with the camera stack right now thanks to a libcamera update triggered by the RPi people. On it.

1 Like

Looks like you've closed the other issue so if I get an updated image from the rpi imager I should be good?

Yes, should be built today

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.