Octoprint server runs and I can't SSH or I can SSH and Octoprint server does not

What is the problem?
I am trying to setup OctoPi and I am a complete beginner. This is the first time I have used Linux ever, so I don't know how to do a whole lot... like open, or even locate an error log. I am trying to connect my Pi3b, or even a 4b+ to my Prusa Mk3S+.

I am using Rasberry Pi imager 1.7.1 to flash the OS. I have tried two different OS because I am unsure which one to use, and one wasn't working so I tried another. When I flash just Octopi stable, I constantly get the error of "server not running" when I go to the local address given to me by Fing. When I flash the Octopi-Klipper I am able to log into the address given to me by Fing, and go through the setup wizard. But when I try to print, I get an error saying "Serial in section MCU must be specified"

What did you already try to solve it?
I have been following tutorials for 4 days now. I have reburned the image 50 times trying different things. No matter how many times I burn the Klipper image and check the info, I can not log in via SSH- it gives me a password error, so I don't know how to enter the command to specify. When I flash just the Octopi image, I can SSH but none of the commands I try allow me to go to the server address and access it. I can't get octoprint to run in the Octopi version, and I can't access SSH in the Klipper version- and I don't know the difference between the two, I am just trying to print from my PC, thats all.

Logs (syslog, dmesg, ... no logs, no support)
I understand everything is easier with logs, but I have not been able to find how to access the logs.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
I have a pi3b, a pi4b+, and a Prusa Mk3S+ printer.

Hi :slight_smile:

Just fyi - there is just a Pi 4b - no Pi 4b+ yet.

As long as you use the stock firmware on your printer, you need the default OctoPi version. The Octopi-Klipper image if for Klipper firmware users.
Your stock firmware is a fork of Marlin.

There should be no need to use Fing or something similar - you should be able to reach your OctoPrint server at http://octopi.local or http://octopi.
If that doesn't work you can of course also try it with the ip. If Fing helps in you with that - why not.
Then it's http://ip-of-the-pi e.g.

Since you're able to ssh into the pi I don't think it's a network issue.
I don't know the default credentials for the Klipper image, but its username pi | password raspberry for the default OctoPi image.

There isn't much you can do with just commands besides of restarting the server.

when you're logged into your pi via ssh you should be able to generate a systeminfo bundle (that's all needed logs packed into a zip file) with

~/oprint/bin/octoprint systeminfo .

You can download it for example with WinSCP. It's something like a remote filexplorer over ssh.
Use the same hostname/ip and credentials you used for the ssh connection.

Thanks for the reply.
Yes, my apologies, it is just a 4b, not a 4b+.
I was following others solutions and some of it seemed to be entering commands but as I stated before, this is the first time I have used anything like this, so I know nothing about it, and am just copying other solutions... and probably not even doing that right.
Thanks for the info about Klipper, I had no idea. I can stop messing with that version, because the Prusa is stock. At least I got to see the server for a moment anyway, because I can not access it with the OctoPi image.
I will reflash with OctoPi stable and try to access the server, but I suspect it will not be running- at which point I will type the info you gave me... in the SSH prompt if I am not mistaken. Then download WinSCP and use it to download the logs, if I am understanding correctly.

yep that's correct
fingers crossed :crossed_fingers: