Octoprint server will not start after upgrade

What is the problem?

Octoprint server won't start after in-GUI upgrade (attempt). Server is running on raspbian by following the "installing manually" instructions.
./octoprint/bin/octoprint serve but ps -ef | grep 5000 no longer shows any output. Made a few dozen successful prints before attempting the upgrade.

What did you already try to solve it?

Trying to find the logging directory was tough... Can I make a PR on the wiki's documentation btw?
Searched for "octoprint logging" and found this page which doesn't mention the log path, but luckily I found a forum that mentioned it should be in .octoprint. I'm a linux engineer so I'm confused not to see at least a softlink in /var/log... or some documentation that describes its location.
Then, I find that no logs are generated when executing ./octoprint/bin/octoprint serve, by which I mean that none of the files are updated (ls -ltr .octoprint/logs/). So now I look for the logging configuration in an attempt to adjust the log level, and I find documentation around logging.yaml. However, I see the path should be .octoprint, but no such .octoprint/logging.yaml exists. config.yaml exists but does not mention a logging configuration file. I did not veer from the manual install instructions so I did not configure it to be stored somewhere else.

Have you tried running in safe mode?

  • from command line run octoprint safemode (since OctoPrint 1.3.6)
    ^ tried this, still no 5000 listening

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

I don't think I'd be writing this post if I could find the logs... but maybe I'm unique as a linux engineer trying to fix an application that feels strangely configured to me.

Additional information about your setup

OctoPrint version - ./octoprint/bin/octoprint --version returns nothing... it's pretty broken huh?
OctoPi version - n/a
printer - n/a
firmware - n/a
browser - n/a
operating system - Raspbian 10 (Buster)
... as much data as possible - feel free to ask if I missed any relevant details

By all means feel free to make PRs to the documentation. A lot of stuff is in the FAQ/guides on this forum, and the word logs is a link you can click to tell you were to find them

If you are on the device (which it sounds like you are), then all of the logs are stored under ~/.octoprint/logs - if it does not log there, then there is something wrong. You are looking in the right place by the sounds of it - don't worry about adjusting the logging level, it is already set to INFO which is more than enough for diagnosing big problems like this - the server startup is particularly noisy.

Maybe it needs a reinstall, the upgrade might have got corrupted.

I'm guessing the path to your virtual environment here, but try:

./octoprint/bin/pip install --force-reinstall --no-cache-dir octoprint

More than likely the install was corrupted/failed in some way, usually the first thing to fail is the logging handler so there is no log output generated (although, it should dump the stack trace to console on octoprint serve)

You could also try re-creating your virtual environment, your installed plugins will disappear but their configuration won't, you will just have to reinstall them again.

Should I back up any configuration before attempting this reinstall? I'm not sure where settings, print files, etc. are located.
I don't believe that I have any plugins.

Configuration is all stored under ~/.octoprint by default, the reinstall will not affect this data - it should only be the Python packages that OctoPrint uses.

Looks to be back up. Thanks Charlie :slight_smile:

You mentioned that I was welcome to open a PR. Is there some SCM that backs docs.octoprint.org?

The docs folder of https://github.com/OctoPrint/OctoPrint gets built to there using a couple of GitHub actions.