OctoPrint service won't start

What is the problem?

The OctoPrint service won't start

What did you already do to try to solve it?

Manually starting it

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

No

Additional information about your setup

Raspberry Pi 3B

Attached is the log file. It won't change after trying to start OctoPrint.
octoprint.log (389.1 KB)

I'm going to guess that one of your plugins is causing the problem. Please run in safe mode and that should verify my assumption. The blue text strings are links that will provide additional instruction if you need it.

Did that happen after you tried to use /media/usb?

Yes! In Firmware Updater

After starting it from the command line, not the services way, I saw the output of the program which was helpful. The error was something in the config.yaml file, it seems like a corruption has occurred there because the file was cut off. I switched it with the backup file (Thanks for that) and all is good now.

1 Like