Octoprint shows Starting forever but print job does not start

What is the problem?

Launched the print job from PrusaSlicer 2.2.0 but on the OctoPrint browser, the "State: Starting" shows up forever and there is no printing. Print Time and Print Time Left are both empty. On the dashboard, Tool 24C and Target 0C. Full circular ring in blue surrounds the word Job.

What did you already try to solve it?

Restarted Octoprint a few times and tried and tried again for a few times.

Have you tried running in safe mode and if so did it solve the issue?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

64Bit 0.18 nightlies has been installed on RPi4 4GB.

We cannot help you without logs. Please provide them.


Try running in safe mode too, please. It will rule out any plugins being the issue.

1 Like

Thanks for the suggestion. It works when I chose Safe Mode :smiley:

When I installed Octoprint few months ago, I could see what the printer was doing under Control. By double checking on the window, I could enlarge the screen. After reinstalling Octoprint but with version 64Bit 0.18 nightlies, double clicking the video feed window does not enlarge the window. Is it a bug?

I have the following Plugins according to the Plugin Manger (I put a * at the end if I installed those plugins myself as I recall):

Active Command Notification Support, Active Command Prompt Support, Announcement Plugin, Anonymous Usage Tracking, Application Keys Plugin, Backup & Restore, Core Wizard, Dashboard*, Discovery, DisplayLayerProgress Plugin*, Error Tracking, File Check (2020.8.7), Firmware Check (2020.9.23), GCode Viewer, Logging, Octolapse (0.4.0)*, Pi Support Plugin, Software Update, Virtual Printer.

At the beginning I had Emergency Stop Simplified but it kept asking me to configure which I don't know how to do it. The button also did not show up so I uninstalled it.

Does the Logs include any information such as file name, user name, IP address, part of the design based on the commands and other information?

It is a very long long list depending on when I do the copy and paste. So just the beginning ones are OK?

It will show the file name, and your user name but only your internal IP address - nothing that I would consider 'private'. Don't copy and paste them, upload the file using the image icon.

Are you sure it is not OctoLapse configuration, since I know that can be configured to show a 'snapshot plan' on print start, and will put the job on hold until you accept it's plan? Maybe this does not show up when you upload from PS

One thing to keep in mind is the nightly builds are beta.
Since it runs as it should in safe mode, disable all the plugins you installed. try it, enable them 1 at a time until you find the one that it doesn't run after it's enabled. That will be the issue.
Also, some plugins wont show up and will appear as disabled, as the 0,18x builds all run Python3.
Some of the plugin developers haven't updated their plugins to run in Python3 yet.

By OctoLapse configuration, do you mean there is a setting that allows me to enable full screen showing of the video images?

No, the problem you initially posted about.