Octoprint shows The OctoPrint server is currently not running

What is the problem?

The Website says The OctoPrint server is currently not running. It shows the following

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host=127.0.0.1 --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log, there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart.

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

When I type in the commands than noting happen. I flash my SD Card with Raspberry Pi Imager and put the SD Card in the Pi. Then I copy the IP and go on the web interface.

What did you already try to solve it?

I try to type in the codes in PuTTy. Nothing happens.

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

Whats that

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE

What happens if you run /home/pi/oprint/bin/octoprint serve from the command line? What output do you get there?