OctoPrint shuts down immediately after boot


#1

What is the problem?
After a night print and a reboot this morning, OctoPrint shuts down immediately after boot.

What did you already try to solve it?
Swapped SD card to another RasPi with another PS. Same issue.
Usually used RasPi with another OctoPi image runs fine.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Just got some screenshots from the boot and shut down sequence:





#2

Ok, I have it running again. So far.
I took the SD card over to a Linux PC, edited config.yaml to make a safe mode boot.
Deactivated Telegram Notifier what I thought was the issue.
Made a complete start afterwards and its running again.
It's also running with Telegram Notifier.

But.... since then I'm missing the SYS icon in the navbar for shutting down the RasPi.


#3

Update concerning the Telegram Notifier.
Obviously there was still the Shutdown command in the Telegram buffer:


2019-01-27 06:23:28,490 - octoprint.plugins.telegram.listener - INFO - Got a command: '/sys' with parameter: 'sys_do_Shutdown System' in chat 59072666

#4

That is some unexpected kind of problem. Good you found the solution!


#5

The Telegram Notifier was a bit faulty anyway and the author seems to pulled himself back. There are no recent news on github.

But I still miss my System icon in the navbar. I think I make a new install and give OctoPi 0.16.0rc1 a try. But the backup file seems a bit small with 351 kb.