OctoPrint stopped detecting printers

What is the problem?

Octoprint stopped detecting my printers. When I try to connect all I get is " Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)

What did you already try to solve it?

I tried restarting octoprint and the printers, changing the cables and ports.

I was running two printers simultaneously (localhost 5000 and 5001) after the prints finished I could no longer connect either printer.

Printers have no trouble connecting to MatterControl and Cura.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)
SerialException: could not open port 'COM3': WindowsError(5, 'Access is denied.')
2020-08-29 23:26:51,289 - octoprint.util.comm - INFO - Serial detection: Could not open port COM3, baudrate 115200, skipping
2020-08-29 23:26:51,290 - octoprint.util.comm - INFO - Serial detection: Trying port COM3, baudrate 250000
2020-08-29 23:26:51,296 - octoprint.util.comm - INFO - Connecting to port COM3, baudrate 250000
2020-08-29 23:26:51,299 - octoprint.util.comm - ERROR - Unexpected error while connecting to serial port COM3, baudrate 250000 from hook default: SerialException: 'could not open port 'COM3': WindowsError(5, 'Access is denied.')' @ comm.py:_open_serial:2784
Traceback (most recent call last):
File "c:\octoprint\venv\lib\site-packages\octoprint\util\comm.py", line 2784, in _open_serial
settings().getFloat(["serial", "timeout", "connection"]))
File "c:\octoprint\venv\lib\site-packages\octoprint\util\comm.py", line 2765, in default
File "c:\octoprint\venv\lib\site-packages\serial\serialwin32.py", line 62, in open
raise SerialException("could not open port {!r}: {!r}".format(self.portstr, ctypes.WinError()))
SerialException: could not open port 'COM3': WindowsError(5, 'Access is denied.')

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Im running octoprint 1.4.2, on windows 10

Access denied likely means something else is using it. Close (not just disconnect) MatterControl and Cura and anything else similar, then try again.

1 Like

Can you connect to the printer with pronterface?

1 Like

Thanks Charlie, I think that was it. Restarted everything and opened the two instances of ofctoprint before cura and it worked.

1 Like

I haven't tried pronterface, looks interesting. Might try it later. Thanks

1 Like