Octoprint stopped working after reboot

What is the problem?
Hi Everyone, i was using octoprint normally when i noticed the camera wasn't working, so i rebooted the system with the botton on the UI and after few second nothing was working anymore.

What did you already try to solve it?
I tried plugging in the PI4 with the ethernet cable but it doesn't appear in the modem either.

Additional comments
The power led and the fan for the cooling system are up and running. I don't think anything happened to the raspberry, the last thing i was doing on octoprint was running the bed calibration with a plugin.

How can i try to solve it?
Is this connectivity/webcam issue related to something else?
is running a clean install of octoprint on the sd the only solution? is so there's a way to save the plugin i installed with their config or retrive the backup i did on the settings menu?

Hello @puroidrogeno !

You may attach a HDMI TV/monitor to the Pi. If all works correct, at the end of the startup sequence there should be the IP address of the Pi. You can use that to connect to the Pi.

Hi, thank you for the tip, i will try and let you know!

@Ewald_Ikemann hi again, sorry for the late response but i had to put my hands on the right cable before doing the test.

I just tried and upon giving power to the pi4 the screen just stayed black.

Any other tips?

Anyone has any other ideas?

You may try with another SD card,

BTW: How do you usually reboot?

usually i use the ui buttons to shut down the system, then when the server is off i turn off the power switch.
anyways, i will try with another SD and see what can i do :slightly_smiling_face:

1 Like

hi @Ewald_Ikemann, i've tried different thing.
i've tried with a new sd but it has the same problem.
i noticed when i boot the pi4 with an sd card connected the act led (green one) is blinking really fast, but i can't define how many is doing.
meanwhile when i booted it without an sd card connected i manage to see the bios on screen and the act led was a steady green.

Any idea on how to make it work again?

Thanks

Do you have the chance to connect an HDMI TV/monitor to the Pi?

There should be a startup sequence when you power the Pi.
This can give clues on what is going on.

Hi,



This is what i see when i boot without a micro SD card.
As i stated before when i try with an sd with octoprint installed i get a blinking ACT led and no signal for the screen, I've tried a couple of different of them woth the same result.

If i can provide anything else to help the debugging let me know.

Thanks again for helping me through this!

And what do you get when you boot with SD card?

A black screen and the blinking led:

Blinking led

Hi @Ewald_Ikemann ,
I've tried adding the sd card once on the bios screen, this is what happen before going into black screen:

I've performed the same test with a couples of sd card and an usb stick.
All of them after what it seems an initial bootload results in a black screen as you can see in my previous message.

You can see the full video Here