Octoprint stops recognizing password, SSH errors

What is the problem?

Octoprint no longer lets me login with credentials. Booting up octoprint doesn't usually ask for login or password, but now it does and I cannot access.

What did you already try to solve it?

I tried SSHing in to change a password. but I get errors like: ERROR:octoprint.settings:Could not write test file to /home/pi/.octoprint/logs/. testballoon.txt
OSError: [Errno 28] No space left on device

Have you tried running in safe mode?

I'm not familiar with that process

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

rpi 4 running Octoprint 1.8.6 and Octopi 0.18.0. Connected to an Ender 3 V2 running TH3D Unified Firmware. Typically I access this via Safari on macOS or via OctoEverywhere using an OctoPod app. This system has worked fine until this morning when I discovered I'm no longer able to access Octoprint.

Hello @SomethingNicer !

For the Web login:
Do you have something like NoScript installed?

BTW: How do you usually shutdown the Pi?

I don't have no script. Usually when I want to shut down the pi I go to terminal and use sudo reboot

sudo reboot for shutdown?

Sorry, I don't typically shut it down so I use the reboot command when I need to restart. When I do shut down, I do so from within the Web UI

@SomethingNicer did you get this fixed?

This is suggesting that your SD card is out of storage space. If you still have SSH access, could you run df -h and paste the output here to show the disk usage? What size SD card/storage do you have in your Pi?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.