Octoprint stops when I connect


#1

What is the problem?
When my printer is running and I login to Octoprint then press the connect to printer button it stops my 3d print. If I connect first then start a print everything is fine. I though with Octoprint at anytime and at any place I could just log in and check to see how everything is running.
What did you already try to solve it?
I tried to reinstall from scratch but that is about all I have down to try and fix it.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
I have the newest version of Octoprint as of today 2019/01/20 I am running a cr-10 with firmware 1.1.7 0r 1.8. Any other information will be provided on request.
Thanks for all the help in advance


#2

When printer boards make a USB connection, a reset is performed on the printer board. This is not a fault of OctoPrint, it's a feature/fault/what ever of the printer board.


#3

I never said anything was wrong with Octoprint. How do I fix this issue, how should I configure it so it stops doing this?


#4

Sorry, I thought so because of

The reset hardware related. When the USB chip detects a connection, it triggers the reset on the board. So no easy way to have a workaround with this. Just leave OctoPrint connected and powered with your printer on from the beginning.

BTW: OctoPrint first uses is as a print server and is used for storing GCODE files and sending them directly to the printer. There is no real need for SD cards on the printer (as far I read for your first post)