OctoPrint suddenly stopped working overnight

What is the problem?

So yesterday I installed a new plugin, filamentsensorsimplified since I installed a filamentrunout sensor and it seemed to work great, but suddenly this morning I was about to print something and an error showed in my Octoprint page.

What did you already try to solve it?

I tried restarting the pi (via SSH) but it won't do it, it just ignores my commands and I also tried to uninstall the plugin but it said the command was unknown.

Have you tried running in safe mode?

I havent tried yet using safe mode, and im not sure how to do it.

Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Hello @ConcealedCoffee !

The blue words are links.

As it seems you are familiar with SSH, you can start OctoPrint in safe mode from there.
When in safe mode, you can delete the new plugin from within the plugin manager.

So I tried to restart using safe mode and it still doesen't work, im using Putty and the only option to start in safemode was editing the config file and add the startOnceInSafeMode: true and after restarting it still wouldn't start, its either not entering on safe mode or it is not working, should I provide the log file? tried to before but an error occured, probably the file is too large.

Thank you btw, I really appreciate ur help!

So I just found the fix, as it turns out the filament sensor simplified plugin kept sending requests to check if the filament was there or not, and since the sensor was off (turns off with the printer) it kept filling the log file, which turns out got too big and made everything crash, couldn't even start on safe mode. I just deleted the log file, rebooted and it works so case solved! Thanks!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.