Octoprint suddenly will not connect to my Ender3!

I'm at my wits end with this I really need help guys.

What is the problem?
I can not get my octoprint to connect with usb to my ender 3
What did you already try to solve it?
I've tried updating my raspberry pi
I've tried 5 different cable (some with ferrets,some shielded, short and long cables,
restarting printer,raspbery pi and octoprint
tried all USB ports on my rasp pi
countless hours researching
tried dmesg and lsusb
Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)
octoprint-5.log (60.1 KB)
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)
octoprint 1.3.11
octopi 0.15.1
Ender3 using latest TH3D firmware
using iMac with safari browser
on high Sierra OS

Hi @Veeman_23!

Your log says:

2019-08-23 18:20:15,621 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial port" to "Error: Failed to autodetect serial port, please set it manually."
2019-08-23 18:20:15,625 - octoprint.util.comm - INFO - Changing monitoring state from "Error: Failed to autodetect serial port, please set it manually." to "Detecting serial port"
2019-08-23 18:20:15,730 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial port" to "Error: Failed to autodetect serial port, please set it manually."

Have you tried to set the baudrate and/or port manually?

yes I've tried every baud rate in the drop down menu, I usually leave it on 115200. and I can't figure out how to set it manually? I've read that if my raspberry pi OS isn't detecting my printer then setting my com port manually would have no effect,is this correct? I also don't think I'm have under voltage problems I am however also using a USB port on the pi to power my ezabl sensor.but I've had this issue since I got the printer and only recently installed the auto level sensor.i have tried disconnecting it and having no other USB ports in use while trying to connect and it still won't work.

also all of the cables I have tried work to communicate directly from my Mac to the printer using Arduino ide.

ok so I reflashed the sd card for the rpi and put a fresh install on it and it still will not connect.i am so frustrated with this.im out of ideas now on what to do.Other than this my rpi seems to be working normal, camera works,octoprint anywhere app works,my ezabl sensor that is powered from the pi off usb even works.but the dam printer won't connect.

  • Run this in Safe Mode and see if that helps
  • Disconnect anything other than the printer (no camera)
  • Verify that you have good power to the Pi (5V @ 2.5A) and the wall outlet measures what it's supposed to be measuring

I tried safe mode today before reinstalling octopi but I know I left the camera cable still on.i have a rpi camera that is run from the ribbon cable off the camera interface, its not usb, should I still disconnect it?

Disconnect all other things: the camera, the EZABL sensor (since that's USB).

ok so I ended up picking up another raspberry pi 3 b+ and I'm getting the exact same error. why would two raspberry pi's not see my printer? if I disconnect my ezabl which is powered by usb from the pi and works fines well as the usb that I'm trying to connect my printer to I run dimes but it tells me the same info as when those two things are plugged in? no difference that I can see.i know the usb on the printer is fine because I can still connect to say Arduino ide and flash my firmware directly from my iMac.

Are you saying that if you disconnect the EZABL from your Pi everything works fine?

1 Like

Sorry let me clarify, I was meaning that my ezabl sensor is powered from USB on my raspi. Which works fine. But still have no connection to my Ender 3

Then try without the EZABL connected to the Pi

1 Like

I tried that. I haven’t been able to connect to octoprint in over a week now.

Have you tried to connect to your printer from PC with Pronterface or so?

I have not tried pronterface yet. But I can connect directly from my Mac to Ender 3 with arduino ide to flash my board.

So that seems to work.
Can you share the serial.log?

Where can I find my serial log? Is this also in octoprint under logging?

Note that serial.log is highlighted and if you click on it, it will take you to a page that should answer your question. You also have to enable serial logging on OctoPrint.

here are todays logs.
octoprint-7.log (2.4 MB) serial-2.log (870 Bytes)

Looking at the logs (which you can also do) shows that auto-detecting the serial port is failing, i.e. OctoPrint can't find the printer.

Unplug the printer from the RPi. Run the command "lsusb". Plug in the printer. Run the command "lsusb". The output of the second command should show one more device than the output of the first command. If it does not, then you may have a bad cable or a bad USB port on your RPi (try a different port). If it does show a new device, then someone else may have to help as I'm not sure where to go from here, lol.