OctoPrint + Tasmotta - can't turn off printer automatically

#1

Hello.
I'm using :

  • an up-to-date OctoPrint (on a PINE64 board) and USB connected to a CR-10S
  • the tasmotta plugin with a SonOff S20 socket (the socket has the 192.168.8.61 IP)

Manually turning on/off the printer through the tasmotta plugin works fine.

My problem is that : the printer is NOT automatically shutdown when the print is done.
OctoPrint is currently sending the "web notification" about the printer about to be shutdown ... but nothing happens.
Again, if i manually click the "power" button in the top bar (green flash), it works fine and the SonOff S20 socket is powered off - that seems to validate that my SonOff socket + Tasmotta plugin are correctly configured.

I have no idea where the problem may be ...

Here are some screenshots :

Shutdown printer option : seems OK

Shutdown "web notification" (red notification in the top right corner) appears correctly : seems that OctoPrint is correctly taking that event in consideration.

Tasmotta configuration : seems OK as the manual on/off are working

Shutdown configuration : ??? (i've tryed with the " 1" for the index in the parameter, but it doesn't help)

Any idea ? I have read several things but haven't been able to find any clear informations about what my problem may be...

#2

If my plugin is working to control your plug from the button then the control via GCODE would need to be tested by using the commands in terminal and verifying that the plug is toggling back and forth with M80 192.168.8.61 1 / M81 192.168.8.61 1. commands. If that is working then the issue is in the Shutdown Printer plugin. But to be honest, if you just want to shutdown the printer after the print is complete and the GCODE commands are working, you can just add that in OctoPrint's default GCODE On Print Complete commands.

#3

Thanks for your input.

I've tryed as you said.
M80 code is not working, but it's probably normal (and i don't need it).
M81 in terminal window was working fine with my current exception (and was shutting down the sonoff socket).

So i did as you said, i've added that M81 command at the end of the print processes, and indeed now it's working (all in all, without the shutdown feature).