OctoPrint-Telegram time wrong

What is the problem?

I'm using OctoPrint-Telegram and the completion estimates it sends are an hour too early. Octoprint itself has timezone set correctly (I checked file upload times and it's correct) so I dont really know where this wrong time is coming form.

What did you already try to solve it?

WRITE HERE

Have you tried running in safe mode?

No

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:106.0) Gecko/20100101 Firefox/106.0
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 1
env.hardware.freq: 1000
env.hardware.ram: 386322432
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi Zero W Rev 1.1
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_check_enabled: true
env.plugins.pi_support.throttle_check_functional: true
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.last_safe_mode.date: unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: false
octoprint.version: 1.8.6
printer.firmware: Marlin 2.0.7.2 (Feb 27 2021 17:53:38)
systeminfo.generated: 2022-10-23T19:50:00Z
systeminfo.generator: systemapi

Have you set OctoPi to your local time zone?