OctoPrint tells me that my printer's firmware lacks mandatory safety features, what does this mean?

@sciaio Looks like a bug. The code should detect that it's a version > 1.1.2 and not warn in that case, but this doesn't seem to work for some reason. I know it worked when I last tested it but either a real printer behaves slightly differently somewhere there or something broke between implementation and release of 1.3.11. Could you please open a bug report and make sure to include a serial.log (not a copy of the Terminal tab contents but an actual log file) so I can test this again?

edit Never mind, found it. It's.... a really stupid bug.

Thanks @foosel , really appreciate it. Hope that was helpful