Octoprint timelapse/octolapse not working on btt cb1

What is the problem?

Ive been ripping my hair out for days trying to get this to work, i have octoprint installed on a bbt cb1 and everything works expect for timelapse or octolapse, the stream works fine, even visiting the url for the snapshot in my browser works but everytime i try to use it i get " Camera Test Failed

Errors were detected - Unable to connect to the provided snapshot URL of http://BTT-CB1.local:8002/?action=snapshot for the 'Webcam - Default OctoPi 0.16.0' camera profile"
Im still pretty new to linux so i dont really know how to really maneuver around in side the cb1 but i just really want to get this working

What did you already try to solve it?

multiple installs of octoprint using octo_deplay/ octo_install

Have you tried running in safe mode?

yes

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20221203065736.zip (73.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octopri0nt 1.8.6
Ender 3 v2 custom firmware
chrome
win 11

For the snapshot URL, try http://127.0.0.1:8002/?action=snapshot and see if that works in OctoPrint's webcam & timelapse settings. Double check you have the correct port number, octoprint_install starts at 8000 I believe so pay attention to how you installed the camera streamer in the first place.

do you know how i would even go about changing that? Ive tried looking for the octoprint text file to change settings for octoprint but im unable to find it on the cb1s files using WinSCP