Octoprint Touchscreen on USB Hub wont work

What is the problem?

I have a Raspberry Pi 3 Modell B+ and want to run a webcam and a 7 inch display with the printer. because of the power consumption i bought a usb hub to plugin the webcam and the display. display and touch work fine when plugged in into the raspberry (raspberry shuts down while printing with the display connected). when i start the whole system plugged into the usb hub the printer and the webcam works fine. the display works too (octoscreen) but not the touchscreen. when i remove the usb of the display and put it back into the hub while running the touch functions works. when i reboot the pi, the touchscreen wont work anymore.

Display: 7 Inch, HDMI, and USB for power and touchfunction

USB Hub:

D-Link DUB-H7 7-Port USB 2.0 Hub

What did you already try to solve it?

Reinstalled the octoprint, updated and upgradet the system. used every usb port of the pi and the hub. tried only the display on the hub etc.

Installed the display like written on the banggood page without a driver (havn't found one either):

Max_usb_current = 1
Hdmi_group = 2
Hdmi_mode = 1
Hdmi_mode = 87
Hdmi_cvt 1024 600 60 6 0 0 0

tried different power supplies for the pi, so i can run the lcd plugged into the pi. had crashes with all of them while printing. currently i use this one, which was recommendet for the pi:

Hope someone can help me with my problem. looked through half of the internet for a solution :wink:

(sorry for my english i m not native)

Hi :slight_smile:

I guess it would be nice if we could get everything to work with the pis usb ports.
Let's check for undervoltage warnings first - so we can rule that out.

Please upload a systeminfo bundle

Ok. Thanks for the fast answer. The octopi is pretty fresh reinstalled. I guess the best results would be to run the pi with the Webcam and Display plugged into it in a print tomorrow (very late now :wink: ) and Post the systembundle afterwards. Data from crashes should be deleted with a fresh install or m i wrong?

Thanks again for the fast answer!

Yep that`s the right approach :slight_smile:

yes the entire sd card is deleted when you flash a fresh image

After i had some problems with the printer, i did like 2-3 prints were nothing went wrong. today the printer stopped again while printing. just stopps and holds temperature while the nozzle is in the print (not a good feeling :joy:

After i rebooted the pi, i downloaded the systeminfo bundle. I hope you can see what the problem is. I had no voltage warnings or something like that.

octoprint-systeminfo-20211026132108.zip (66.5 KB)

  • webcam, printer, 7 inch touchscreen plugged directly into the octopi
  • octopi freezes while printing (touchscreen freezes, browser octopri not

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.