Octoprint & Ultimaker start without any heating


#1

I am using the latest version of Octoprint (1.3.9) on my Ultimaker 2 with Tinkergnome Firmware 17.10.01 Whatever I do, octoprint starts printing immediately. No nozzle heating, no bed heating.

If I use a finished sliced GCode file cut by S3D, or the Octoprint CuraEngine, imported Cura 15.04.5 profile, - Octoprint ignore the heating process completely.

Here are the start codes - any ideas?!?? By the way, the Octoprint Gcode scripts are all empty. Printing via SD Card without using Octoprint, everthing works fine.

Cura Setting Start Code

M190 S68
M104 S222
M109 S222
M82 ;absolute extrusion mode
G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
G28 X0 Y0 ;move X/Y to min endstops
G28 Z0 ;move Z to min endstops
G1 F12000 X5 Y10 ; Cura HEATUP_POSITION_COMMAND (edited)
G1 F2400 Z30 ; bring plate to Cura PRIMING_HEIGTH (edited) with Cura HOMING_FEEDRATE
G1 Z25.0 F9000 ;move the platform down 15mm
G92 E0 ;zero the extruded lengthG1 F500 E20 ; undo end of print/abort retraction
G92 E0 ; zero the extruded length
G1 F50 E6 ; additional priming
G1 F2400 X5 Y50 Z0.3 ; wipe start position
G92 E0 ; zero the extruded length
G1 F225 Y65 E1 ; move 15mm and extrude
G92 E0 ; zero the extruded length
G1 F2100 Y80 E1 ; move 15mm
G92 E0 ; zero the extruded length
M42 S100 ; LED 40% ON
M117 Printing...

Gcode of a file sliced with S3D

G90
M82
M106 S0
M140 S75
M190 S75
M104 S240 T0
M109 S240 T0
G28 ; home all axes
G1 F6000 Z5 X5 Y10 ; Cura HEATUP_POSITION_COMMAND (edited)
G1 F2400 Z30 ; bring plate to Cura PRIMING_HEIGTH (edited) with Cura HOMING_FEEDRATE
G92 E0 ; zero the extruded length
G1 F500 E30 ; undo end of print/abort retraction
G92 E0 ; zero the extruded length
G1 F50 E6 ; additional priming
G1 F2400 X5 Y50 Z0.2 ; wipe start position
G92 E0 ; zero the extruded length
G1 F225 Y65 E15 ; move 15mm and extrude
G92 E0 ; zero the extruded length
G1 F2100 Y80 E20 ; move 15mm
G92 E0 ; zero the extruded length

#2

If your printer is driving on past blocking commands like M190 then it's the firmware rather than OctoPrint, right?

Read things

"Bug in the firmware, I made a mistake and this swapped the "wait for heating" to "wait for cooldown" on the bed M190 command. I've fixed it for the next version..."

So it should hopefully be fixed soon. In the mean time you can manually heat the bed via the Maintenance menu. I usually start heating the bed when I sit down to do the slicing so it's close to hot when I want to start printing.

Sounds like you need to chase a newer firmware version for yours.


#3

You have to make sure you don’t slice for with the “UltiGcode” gcode flavour, but use “Marlin” instead. UltiGcode uses its own start sequence controlled by the printer firmware, but this does not work when printing over USB.


#4

WTF :hot_face: - the reason for all my problems is Octolaps.

I'm using Octolaps in version 0.3.4rc1.dev3 Maybe the Test Mode option is a new feature as I've never done this before. I'm pretty sure I didn't select this option - it has to be set by default - maybe?!?

The function of this option is :

............................................................................................................................
Test your time-lapse settings without using a filament. This function is experimental, so make sure you unload your filament and monitor your printer during the test.
.............................................................................................................................

Thus, all extrusion and heating settings are overwritten by the Octolaps test mode. To remember this function, a popup window would be a nice tool :exploding_head:


#5

Thanks for letting us know but now casually stroll like DiCaprio over to the repository for OctoLapse and let the author know in the Issues section. That's the best way of getting this updated.