Octoprint unwarrantedly heating bed when connecting to printer

What is the problem?
I just installed octoprint on my custom printer that's controlled by an SKR pro V1.2. However, the moment I connect my raspberry pi 3A+ loaded with octoprint, the bed starts heating. I can tell by looking at the LED of the bed heater Mosfet module that lights up right as I connect the usb cable (disconnecting it also fixes it instantly). This causes the bed temp to rise without stopping.

What did you already try to solve it?
I've tried covering off the USB power lead, since I've read that might be necessary (although I don't know if it is forthis mainboard), but that didn't seem to help - at least, I think. Putting on the tape wasn't easy and I'm not 100% sure it's isolated.
Is there rather a software/firmware issue? Can anybody point me in the right direction?

many thanks!

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)
Raspberry pi 3A+
mainboard = SKR pro V1.2 (32bit, running marlin)
long usb cable

Sounds like maybe a command is being set to the printer over the serial. Hard to say really. Not even sure if you have OP running or if this is a cold connection with the Pi off.

Some questions that I would try to answer would be what happens if I try to use the Printers interface to turn it off? Can the bed heater be turned off and once that is done does it seem to operate normally? Or is it just stuck on. If it was stuck on, Is it the connection of the cable or is it the connection of the pi itself. Do you get the same result if you just connect a laptop to the printer?

We will need a bit more to go on than you have provided. Hope my questions get you moving in the right direction.

Upon further debugging, I don't think the printer is getting any heating commands. The set temp on the bed stays at 0 both on the printer LCD readout, as well as on octoprint. changing the set temp up and down does nothing (I mean, it does change the set temp, but it doesn't influence the bed heater at all). Also, the bed starts heating the instant I connect the USB cable to the pi, even before I officially connect the printer to the pi using the "connect" button on my octoprint interface. I'll have to get back on you connecting the printer to regular laptop, that's a good test indeed.

Thanks for your help so far!

That sounds like a severe electrical issue with your printer. The USB port should definitely definitely not be connected to the bed heater like that.


Yeah, I figured :smile: I checked some more and found out that the bed starts heating the moment my printer main board's ground is connected to the ground of the raspberry pi. It doesn't show this behaviour when connected to a laptop though.

You could try a USB Voltage Isolator but I agree with @Charlie_Powell, there is probably something wrong.

I checked the voltage across the bed heater pins, and it's only about 0.4V. I did notice that the bed heats only slowly, and that the indicating LED lights up dimly. Seems like something is causing this small voltage, causing the bed to heat up slightly.

My bed is not wired directly to the dedicated, high current bed output of my mainboard. Instead, I'm using a mosfet module that's being switched by an unused regular heater port. I changed the way I wired the signal from my mainboard to the mosfet module. I connected it to the B-CTL wires, instead of the signal-ground ones. Sources seem conflicting on which input to use (and documentation is scarce), but now everything seems to work. The Pi's connection no longer heats anything up.

That being said, it's still strange I got this behaviour in the first place. I'll definitely keep an eye out for further indications that the setup is bad.

Thank you for the help!