OctoPrint update bricked a dozen Pis. Pls advise

I run an educational lab with about a dozen Prusa machines which students can access via octopi's. Last week I was prompted to update the pi's which I did, and subsequently all of to pi's are giving me "The OctoPrint server is currently not running" page. I have had to re-flash the Pi's a couple of times this year already and am very frustrated. I would like to avoid repeating this process now or in the future.
In my experience many of the help pages seem to presuppose a moderate to advanced level of Linux or programming knowledge on the part of the reader which I do not possess. This system was set up by a predecessor of mine with a software background.

What did you already try to solve it?

I have allowed the Pi's substantial time to restart on their own (re: hours). I have also connected to them via SSH and attempted to follow the directions on the "The OctoPrint server is currently not running" page, however none of them seem to work.
The line beginning "ps -ef | grep..." does not return any result in SSH. Entering "ps -ef" by itself returns a list of entries however none of them appear to match the "pi 1441..." line indicated on the web page.

Posted below is the CL from when I attempted to restart octoprint on the Pi and when I attempted to access the log files. Neither seems to have worked from what I can tell:

pi@octopi-hull:~ sudo service octoprint restart pi@octopi-hull:~ ~/.octoprint/logs/octoprint.log
-bash: /home/pi/.octoprint/logs/octoprint.log: Permission denied
pi@octopi-hull:~ $ sudo ~/.octoprint/logs/octoprint.log
[sudo] password for pi:
sudo: /home/pi/.octoprint/logs/octoprint.log: command not found

Have you tried running in safe mode?

No, I am not sure how to do this via SSH

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I don't know what this means

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

When I access via SSH it says that the OctoPrint version is 1.8.7 and the OctoPi version is 0.18.0 . I am running a mix of Prusa i3 MK3S+ printers and Prusa MINI+ printers which all have their firmware up to date. The OctoPi's are a mix of Raspberry Pi 3 v1.2 and Pi 4 model B. On each OctoPi I have also installed the following plugins: FileManager, Autoselect, and OctoPrint-Prusa-Mini-ETA.

click the link.

I assume I'm missing something from the SSH directions on the linked page. Here's what I got so far. I also tried entering the IP address with "/recovery" and I got the same error page saying the server is currently not running.

pi@octopi-hull:~ octoprint systeinfo
-bash: : command not found pi@octopi-hull:~ octoprint systemino
-bash: octoprint: command not found
pi@octopi-hull:~ connectivity.connection_check: -bash: connectivity.connection_check:: command not found pi@octopi-hull:~ systeminfo
-bash: systeminfo: command not found

A little further down it mentions the full path. Try this command

~/oprint/bin/octoprint systeminfo .

make sure to include the . at the end.

in most cases the commands below will force a reinstall.

source ~/oprint/bin/activate
pip install --force-reinstall --no-cache-dir OctoPrint==1.8.7
sudo service octoprint restart

we really just need to see what's in octoprint.log and check for errors.

cat ~/.octoprint/logs/octoprint.log

I have the same problem after the last update.

So I had not previously realized that OctoPi updates separately from OctoPrint and I was still back on OctoPi version 0.18.0
I am in the process of re-flashing the new version of OctoPi on my raspberry's and it seems to be working.

Is there a way to update OctoPi without reflashing the memory?
Also I think it might be helpful if there was a warning notification or other automatic error check for overly-dissimilar versions of OctoPi and OctoPrint.

Im also on version 0.18.0 but why shouldnt this version work with the latest octoprint version? And why can I update to the version if there not compatible?

This is the manual reinstall steps for OctoPrint.

1 Like

It shouldn't, but there are several reasons that have been documented of possible reasons of it breaking. But without any logs to see what the errors are we don't know which one will fix the issues you are having.


I'll just add that OctoPrint will update to the latest version on both OctoPi 0.18.0 and OctoPi 1.0.0. If you need to reimage the SD card, I'd recommend using the OctoPi 1.0.0 image but be aware that the camera stack is going to be updated in the near future which will probably require another reimage.

Another very useful tool to have around is a USB SD card reader/writer. This will allow you to move files from an older micro SD card to a newer micro SD card as well as give you the ability to clone a running system to use as a backup.

I took this opportunity of a broad re-image to swap out a couple of my cards for industrial cards so I think I still have a couple of cards with the crashed image on them -- can I pull the log file if I put the card into a PC?

Yes you can. If that PC is running Linux then its fairly trivial. If it is running Windows the the process is more difficult because first you need the ability to mount Linux partitions (ext4) under Windows. Applications exist to do this one of which is linux reader. I think it can also be done with the Windows Subsystem for Linux.

Oooh that would be interesting - I've used the DiskInternals Linux reader you linked before, but it was always a bit clunky I felt. If It can be done through WSL that would be lovely.

Looks like you need Windows 11 build 22000 or above. My main desktop is Windows 10 (hardware not compatible with 11) but I have another system with Windows 11. I'll go play and report back.

I thought I met all the requirements but I can't get it to work....

Looks like I need to quit trying... https://github.com/microsoft/WSL/issues/6011

1 Like

When I do this, is then all my data lost? Or do I have have no chanche of keeping my data, because then I can make a new image.

all the settings and uploaded gcode are stored in a different folder altogether (typically /home/pi/.octoprint) so reinstalling doesn't touch those bits.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.