Octoprint usb connection failure

Running with an Wanhao i3 printer.

Just started printing again after an 8 month pause.
Did a few prints then decided to upgrade to latest octoprint, cannot now connect to the

Never had a problem with usb connection before, and nothing changed physically since the upgrade.

octoPrint 1.3.11
OctoPi 0.13.0

According to the octoprint.log file i was previously running version 1.3.8
I may try a revert to see if that works.

Tried safe mode, no difference.
Tried physical restart, no differnece.
Tried auto detect on serial port speed, was using 115200. no difference
Tried increased connection, autodetection and initial-baud-pase all to 30 seconds, no difference - failure is detected within a few seconds - so it is not really a timeout problem.

Checked permissions on /dev/ttyUSB0 and confirmed that 'pi' user has required groups.

This looks like a complete failure to connect to the usb device

Octoprint log
octoprint.log (115.0 KB)

Enabled serial degug log:

2019-07-28 07:55:32,526 - Changing monitoring state from "Offline" to "Detecting serial port"
2019-07-28 07:55:32,592 - Serial port list: ['/dev/ttyUSB0', '/dev/ttyUSB0']
2019-07-28 07:55:32,593 - Trying /dev/ttyUSB0
2019-07-28 07:55:38,315 - Changing monitoring state from "Detecting serial port" to "Error: C
onnection error, see Terminal tab"
2019-07-28 07:55:38,335 - Unexpected error while connecting to serial port: AUTO IspError: ''
Timeout'' @ comm.py:_openSerial:2611 (hook default)


Typical just when you request help you manage to solve the problem.

Turns out that just selecting /dev/ttyUSB0 as the serial on the UI was enough to get this solved!

Somehow it had defaulted to 'AUTO' and all the logging messges were saying /dev/ttyUSB0 even though it couldn't of been.

1 Like