Octoprint web interface not reachable via mobile devices

What is the problem?
I have been using Octoprint (Octopi) on a Pi 3B+ for a good while, with a strange issue. I intermittently cannot connect from mobile devices (phone or tablet). All I get is a "This site can't be reached" error. this is true for my andrioid phone, my android tablet, or even my wifes ipad. All are on the same wifi network (tablet and ipad have no cellular). If I try to connect from windows computers, it always works. This is true for a desktop that has a wired connection to the router or on a laptop with a wifi connection. By intermittent, I means that it will work, then just stop working for weeks or months straight, then might start working again (usually not working more than working). Today, I loaded Octo4a on and old phone to try it out, and was amazed to have the same issue (web interface works for wired and wifi windows computers, not with android phone or tablet, or ipad). Note, I haven't plugged the octo4a into the printer yet (waiting for OTC power passthrough cord). While trying to figire this out, the Pi 3B+ randomly started working on my phone, but if history is any indication, it won't work for long. All of this is while on my local network, I am not trying to connect for an outside network. My router is a basic setup (one wifi network, no repearters). Its a Specrum (ISP) provided router, but I cannot find any setting or configuration that would cause this.

What did you already try to solve it?
-reinstalled Octopi (no change)
-tried octo4a on a different device
-tried at least 5 clients (desktop, laptop, phone, tablet, ipad) covering wired and wifi
-tried safe mode, no change

Logs (syslog, dmesg, ... no logs, no support)
-uploaded the system info bundle for both the octopi and octo4a installs. The octopi is a pretty recent re-install from trying to fix this.

octoprint-systeminfo-20230201221741.zip (8.0 KB)
octoprint-systeminfo-20230201161723.zip (18.5 KB)

Are you attempting to connect with a name or with the IP address?

This sounds like a DNS issue. Unless you've done something special, the router should have both the DHCP server and the DNS server and it should be sending its own IP address as the DNS server in the DHCP response packet.

Some sort of DNS thing is different here.
Have never succeeded to connect to octoprint.local just typed in either Edge or Chrome's Address bar even though I can ping the DNS Name.
So till now I've just used the IP Address.

My Home Assistant Pi by comparison can be connected to with just hass:8123 in the address.

Had Play a little here on the Lounge Chair Laptop, found it I used http://octoprint.local is would open the page.

Then subsequent attempt to use just "octoprint.local" as the address work.
Seems as if the URL with the "http://" is now cached in the browser somewhere.

I am trying to connect only by IP address. I have never gotten the octoprint.local to work. The IPs stayed constant, but I have also tried designating a fixed IP with no change. (right now they are on and

octopi.local (not octoprint.local) is a name supplied by the Bonjour Service, an Apple development.

Since @Kawayanan is using IP addresses only, that should eliminate DNS issues and we should be left with a routing issue. We could try using a utility like Ping for iOS or PingTools for Android. From each device, run a ping test to the IP address of the RPi.

If it never worked I'd suspect that the Specrum router was isolating WiFi clients from each other but since you say the laptop on WiFi works reliably, I don't think that's the problem.

In any case, I don't believe OctoPrint has anything to do with this issue. What version of OctoPi is being used? OctoPi is just Raspbian-Lite with OctoPrint and a few other utilities pre-installed.