OctoPrint Will Not Detect Serial Port Needed

#1

Hello Everyone,

I recently aquired a Prusa Mk3s and I want to be able to monitor my prints from it.

Installed Octopi on Rapi Zero W, created the static IP address fine, hooked it up fine, however I can not connect to it in either serial ports /dev/ttyUSB0 /dev/ttyAMA0 . In fact I cant even see USB0 in the drop down section even though I type it in.

I only receive this error....ever....
Offline (Error: IOError: '[Errno 25] Inappropriate ioctl for device' @ comm.py:_readline:2605)

read out

Connecting to: /dev/ttyAMA0
Changing monitoring state from "Offline" to "Opening serial port"
Connected to: Serial<id=0xb0341bd0, open=True>(port='/dev/ttyAMA0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from "Opening serial port" to "Connecting"
Send: N0 M110 N0*125
Unexpected error while reading serial port, please consult octoprint.log for details: IOError: '[Errno 25] Inappropriate ioctl for device' @ comm.py:_readline:2605
Changing monitoring state from "Connecting" to "Offline (Error: IOError: '[Errno 25] Inappropriate ioctl for device' @ comm.py:_readline:2605)"
Connection closed, closing down monitor

OctoPrint version: 1.3.10
OctoPi version: 2018-11-13-octopi-stretch-lite-0.16.0
printer : Prusa MK3s

Please someone help me....

#2

Don't. Use an RPi3 or 3+ instead. I know Prusa recommends the 0W. They sadly didn't talk to me before committing to this or I'd told them how bad of an idea it is. And yes, there are people out there who will probably now go "no Gina, it works flawlessly for me, I don't know what you are talking about" and all I can say to that is "be glad, that thing has serious issues thanks to its wifi chipset, I wouldn't trust it to run my printer and hence will never recommend it".

That is the Pi's serial port. If you have hooked up the printer to the Pi's GPIO header, that is what you want to use, but in order for that to work you need to disable the Pi's own serial console running on it and also switch the internal bluetooth chip to software and the GPIO to hardware serial or you will be in a world of pain.

The (outdated) PrusaPrint image does that for you, OctoPi 0.16 doesn't.

That or /dev/ttyACM0 will only show up if you connect the printer via USB and as far as I remember you also then have to disable USB serial somewhere in the settings of the printer. Or you needed to enable GPIO serial. I'm not sure what the default is.

In general, OctoPrint can only offer you serial connections to connect to if the underlying OS sees them. If it doesn't see them, you need to fix that first.

2 Likes
#3

Thank you very much! I will use a pi3+ then. I really do wish the smaller more package friendly pi worked but I guess it cant be helped.

1 Like