Octoprint will not start after new plugin update applied

What is the problem?

updated today the new update for plugin (sorry did nto catch the proper name but i think it was the system plugin update Was running 1.7.3 and not python 2

What did you already try to solve it?

Tried to boot into safe mode but does not help

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

See log info below if that helps

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

this is an older Pi waiting for chip prices to come down to get a Pi4

Below is the last part of the log entry not really good in SSH and linux but i get around enough
below start just before shut down adn you can see it going into safe mode

Sorry new users limited on what they can include so cant add log info

Maybe this will be enough for system bundle info (from the logs)
2022-03-03 14:01:27,205 - octoprint.environment - INFO - Detected environment is Python 3.7.3 under Linux (linux). Details:
| hardware:
| cores: 1
| freq: 700.0
| ram: 386326528
| os:
| bits: 32
| id: linux
| platform: linux
| plugins:
| pi_support:
| model: Raspberry Pi Model B Rev 2
| octopi_version: 0.18.0
| throttle_state: '0x0'
| python:
| pip: 20.3.3
| version: 3.7.3
| virtualenv: /home/pi/oprint

It would be better to have the whole log file (you can upload it as a file in a comment), to check for errors.

From your SSH prompt, what happens if you run ~/oprint/bin/octoprint serve? Any errors?

i tried to email logs but i think they all got rejected (several days later)

here is the info from the command you asked me to run
~/oprint/bin/octoprint serve
2022-03-03 15:23:08,936 - octoprint.startup - INFO - ******************************************************************************
2022-03-03 15:23:08,952 - octoprint.startup - INFO - Starting OctoPrint 1.7.3
2022-03-03 15:23:08,954 - octoprint.startup - INFO - ******************************************************************************
2022-03-03 15:23:12,415 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity changed from offline to online
2022-03-03 15:23:12,544 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: online
2022-03-03 15:23:12,546 - octoprint.util.connectivity.connectivity_checker - INFO - Connecting to is working
2022-03-03 15:23:12,548 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving octoprint.org is working
2022-03-03 15:23:13,514 - octoprint.startup - INFO - Blacklist processing done, adding 3 blacklisted plugin versions: roomtemp (any), GcodeEditor (>=0.1.1,<=0.2.8), gcodeleveling (>=0.1.0,<=0.1.1)
2022-03-03 15:23:13,908 - octoprint.plugin.core - INFO - Loading plugins from /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins, /home/pi/.octoprint/plugins and installed plugin packages...
2022-03-03 15:23:25,317 - octoprint.plugin.core - INFO - Plugin OctoEverywhere! (1.5.6) is disabled.
2022-03-03 15:23:25,407 - octoprint.plugin.core - INFO - Plugin Long-SD-list-paths (1.1.0) is disabled.
2022-03-03 15:23:28,308 - octoprint.startup - INFO - Added settings overlay from plugin dashboard
2022-03-03 15:23:28,429 - octoprint.plugin.core - INFO - Found 34 plugin(s) providing 32 mixin implementations, 69 hook handlers
2022-03-03 15:23:29,672 - octoprint.server.heartbeat - INFO - Starting server heartbeat, 900.0s interval
2022-03-03 15:23:29,753 - octoprint.cli.server - ERROR - Uncaught exception
Traceback (most recent call last):
File "/home/pi/oprint/bin/octoprint", line 8, in
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/init.py", line 965, in main
octo(args=args, prog_name="octoprint", auto_envvar_prefix="OCTOPRINT")
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 829, in call
return self.main(*args, **kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 782, in main
rv = self.invoke(ctx)
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1259, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1066, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 610, in invoke
return callback(*args, **kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/click/decorators.py", line 21, in new_func
return f(get_current_context(), *args, **kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/cli/server.py", line 329, in serve_command
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/cli/server.py", line 164, in run_server
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/server/init.py", line 371, in run
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/server/init.py", line 2486, in _start_intermediary_server
File "/usr/lib/python3.7/http/server.py", line 137, in server_bind
File "/usr/lib/python3.7/socketserver.py", line 466, in server_bind
OSError: [Errno 98] Address already in use

You can zip the logs and post them here.

it looks like two plugins where installed and when restart happened that is where it failed
but usally when it is a plugin that is the cause of the failure starting in safe mode and then disable the plugin would get you working again but safe mode still fails

octoprintlogs.zip (30.5 KB)

i could not find the upload option but finally found it

I grabbed another SD card and setup an new instance on same Pi. so don't go nuts but I can put the old sd card back in if you want to better the community. the only think I got left is to figure out what api stuff I had setup. already pulled all the plugins i wanted back.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.