Octoprint will not start on M3-ID

###What is the problem?

I have a MAKERGEAR M3-ID that a pervious coworker did unknown things to. Long story short the individual no longer works here. Anyways the problem I am having with the M3 is I am getting the "Octoprint is not currently running" screen:

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint should show a python process.
  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log , there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart .

I am able to SSH into it using putty and got the log. This is my first time doing any of this so I don't exactly know what I am doing and I have googled for hours trying to figure this thing out.

What did you already try to solve it?

I tried to factory reset the printer, using the reset button for more than 60 seconds. The printer went through the appropriate beeps etc and booted back up and connected to the wifi again. I can see it on the router connection page. If it properly reset it should have lost the wifi information etc.

Have you tried running in safe mode and if so did it solve the issue?

I don't know how to enter safe mode.

Complete Logs

Since the log is so long I couldn't upload it here. Text limit was exceeded. Google sheet link:

Additional information about your setup

Again, I have no idea what the previous person tried to do to this unit or how it got in this condition. thanks for making it this far in my post.

If I were you, I would completely reinstall OctoPrint. But, it seems that the printer comes with a custom plugin or something, so you may be out of luck, or it might just be they put their own branding on OctoPrint, and re-sell it, in which case you will be OK.

It's running OctoPrint 1.3.4, which is more than 3 years old. To be honest, I have no clue what might be there. There's very little I (or anyone else) can do to help with that, since whatever we suggest will likely not be applicable.

We have more than one of these printers, do you think there is some way to clone the data off of one and apply it to the damaged one? I could send it in to the manufacturer but would like to avoid that.

If you can access the SD card, then you can clone it quite easily - something like rpi-clone can be used, or other disk imagers.

I will go ahead and give that a try, I just got access to the SD card, its pretty easy to get to.

1 Like