OctoPrint with Geeetech A30 problem


#1

hallo,
ich habe octoprint mit meinem geeetech A30 drucker verbunden. Da die Fördermenge meines extruders überhaupt nicht stimmt möchte ich den Befehl M503 eingeben um E zu ändern. jedoch passiert bei mir nach der Eingabe von M503 garnichts... es wird folglich nichts angezeigt... kann mir jemand erklären wie ich das ändern kann?

Hi,
sorry for my bad english. I just connected my geeetech A30 with my raspberry pi including octoprint. after i got a big problem with my extruder i figured out why my printer still wont print correctly. if i extrude 100mm filament it is acually 125mm so der is an over extrusion. when i want to change the E: setting with octo i know i have to give the order M503, but when i do this nothing happens there comes no information or no possability to change E: maybe someone can tell me why i cant change this setting
thank you


#2

This is Geeetech's webpage for how to do this. But this looks a little complicated.

It may be easier to install the EEPROM Marlin Editor plugin, then use it to set just the "steps/mm" setting to something lower.

Your ratio appears to be 125/100 which is too much. But you can also think of this as 25/125 (20%) which needs be be lowered from the existing setting. If the current setting is 866.69, for example, the new value needs to be 866.69 * 0.8 = 693.35 in order to be close-to-perfect.