OctoPrint won't cancel after 1.3.7 update


#1

What is the problem? When I try to cancel a print... Octoprint shows "canceling print..." until I restart the server.

What did you already try to solve it? Restarted the server, the same happens the next time I tried to cancel printing.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)


#2

Is there a way to get back to version 1.3.6?


#3

I have the log files...I don't know how to display them.


#4

Upload the logs to http://pastebin.com/.


#5

Uploaded. titled. 1.3.7 cancel freeze


#6

or maybe you need this https://pastebin.com/GHmTk7Qm


#7

It looks like you waited about a minute after the cancel and then had OctoPrint restart the machine?

Unfortunately not much is there, so you'll need to enable the serial log and share that too.


#8

On 1.3.6 it canceled right away. In that log I canceled twice and it hung both times.

Can you give me a clue on how to enable the serial log to share?


#9

I found it... I don't want to cancel what I am printing right this sec. I'll start one and cancel it here in a bit.


#10

BTW The print cancels (the printer stops printing) but the web interface freezes.


#11

You're the second one to report that. FYI @foosel.


#12

Wow... Started another print... hit cancel and it worked as before. No problem that time... 3rd times a charm.
I have all the logging on now so if it happens again I will have it.


#13

OctoPrint 1.3.7 introduced a new "Cancelling" state. What that does is that after you hit cancel, instead of immediately going to "Operational" and then sending the after cancel script (which could cause issues if you restarted the print right after) it first goes into that new "Cancelling" state, sends of the after cancel script (and if enabled also position logging) and once all that's been sent to the printer it switches to "Operational" state again.

So OctoPrint sitting on "Cancelling" means that for some reason it could not send all that it expected to send to the printer (or the printer didn't reply to the position log). To find out why that happened I'd need a serial.log though or at the very least the contents of the Terminal tab after the failed cancel.

edit

Just saw that someone also reported this in the bug tracker. See this ticket:

Should you also be using a Replicape, that might already be the explanation and for now you'll simply have to disable position logging on cancel. If not, please chime into this ticket with a fully filled out ticket template (including a serial.log).

Linked under every. single. release announcement. But before you go back it would help tremendously to provide a serial.log of the problem, otherwise you pretty much ensure that this won't be solved.


#14

Ok it happened again today... If I wait long enough the web app does cancel, just takes a long time. And looked like to me the bed temp is still going while it is frozen. While frozen I couldn't get the serial log to download.

Serial log here. https://pastebin.com/4GNeCb9U. I cropped out just the last couple cancels that worked along with the one that hung for a bit then finished.
BTW I am running a Mac OS X 10.13.3 and Safari.


#15

Canceled another print...3min still froze. Bed and nozzle temps still as printing while frozen. 5 Min still frozen. going to restart the server this time. Reload Octoprint web page nozzle and bed heat show Zero then but printer still holding heat. Going to update to 1.3.8


#16

I've been having the same issue with version 1.3.7, I've just rebooted my RP3 when it happens, hopefully 1.3.8 addresses this.


#17

If I pause or cancel a print I am hosed. Pause does pause but then just sits there and never responds cancel will work sometimes.


#18

Pause always worked for me... went to 1.3.8... paused a few times already... worked fine. Canceled once so far... also worked as before.


#19

I hate to say this but is there a way to go back to the previous version??? i have been using Octoprint on my phone and computer with a rasberry pi for over 2 months with a dns website without a problem in one new release is now garbage!! The new version does not cancel, it does not pause...it just locks up and doers nothing until you reboot your system then you lose your print all together! The keyboard controls dont work, nothing works! It even has disconnected from my server for the first time since using it in the middle of a 20 hour print and now i can do nothing until its done printing and have no idea when that might be! Shame on whoever released this upgrade and cost everyone a ton of wasted time and money due to wasted filament! I hate to be a complainer i really do, and i don't complain much if ever! but this really just erks me to the point where i had to complain about it! trust me when there is ever another upgrade I will wait a few months to do it! Lesson learned to all!


#20

Shame on whoever released this upgrade and cost everyone a ton of wasted time and money due to wasted filament

It sounds like you should demand a refund.