OctoPrint won't cancel after 1.3.7 update


#41

The FAQ indicates where to find the magic button. It's there on the Terminal tab under Advanced.


#42

Thanks, but I know where it is.

I can't click it though because the entire UI is unresponsive when it hangs on cancel.


#43

Oh, I see.

There were two work-arounds in the FAQ on this. Both of those were reactive from what I saw. The more proactive one was pressing the Disconnect/Connect in the Connection side panel widget.

And then—if you've seen this more than once—you might just want to take one of those work-arounds as a precautionary step. (I get this one from time to time but not often enough to take any Settings-based measures yet.)


#44

I tried the first workaround - switching off the event based position logging. Hasn't helped.

Unless others are seeing completely different "hang on cancel" behavior from OctoPrint's web interface, I think the second workaround is bogus, as you can't click that button or anything else when it hangs.


#45

They are. Your UI lock-up isn't the normal behaviour at all and it sounds like something else is going on here, otherwise both workarounds would work just fine. The issue described here is contained within OctoPrint's backend and doesn't affect the UI in any way, that remains completely responsive. If you UI is hanging, it has other reasons and you'll need to dig up some logs so that can be investigated further and possibly turned into a bug report.

I think the second workaround is bogus

I'm not in the habit of offering up "bogus workarounds".


#46

For what its worth, this happens to me as well although not every time. Octoprint 1.3.8, marlin 1.1. Tevo tarantula, Rpi 3, windows 10, chrome 65.xxx. I'm not as technologically advanced as most so I really do not know how I can contribute but if any is needed from me just say and if I dont know it or how I'll be sure to ask. Thanks


#47

Had same issue with new CR-10S. I used the Fake Ack and it worked every time after pausing and resuming.
I'm curious where/if this is being sorted out/tested? I don't mind testing for you.
As a note I am running OP 1.3.8.


#48

Foosel indicates that the race condition will be worked on in v1.3.9, for what it's worth.