Octoprint won't complete connection to Ender 3

There are similar threads but none actually look the same.

So here goes - last week everything worked perfect. I updated octoprint and installed the PSU Control plugin and then a day later I attempted a print and the octoprint wouldn't complete the connection.

  • I disabled the plugin - no change.
  • I have tried power cycling everything - No change.
  • I removed all peripheral - no change

Note once in a while it will actually complete the connection but with no consistency

Serial Info:
Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyUSB0, baudrate 115200
Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0xaac2c4f0, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Send: N0 M110 N0125
Recv: start
Recv: echo:Marlin
Send: N0 M110 N0
Recv: echo:start
Recv: echo: External Reset
Recv: Marlin
Recv: echo: Last Updated: 2echo:TF card ok
Recv: Init power off infomation.
Recv: size:
Recv: 585
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

When it actually works, it will get stuck waiting on an ack after the hotend reaches temp. Any thoughts why the ender would not be acking OR why it is not being received?

OctoPrint 1.4.2
Ender 3
Tinker Board

So could you please share the octoprint.log and the serial.log you have been asked for?

After more investigation and searching the forums I found this post that seems to be the same problem... Cannot connect printer after 1.4.2
so I will move my discussion there.

1 Like