Octoprint Won't Control Printer

I have a brand new Raspberry Pi that I installed OctoPrint on. I set up the wifi connection by editing the supplicant file, and set everything up according to the Octoprint startup guide.

I plugged in the sd card and powered up the PI, and connected to the Octorprint server, and everything seems to be working fine. I plugged the USB cable from the Pi into the usb port on my Creality CR-10, and set the port and baud rate to AUTO. I click connect, and after a few seconds, it tells me that my printer is operational, and shows the bed and hot end temps.

I noticed that the fan on my hot end was on, so I went to the contol tab, and clicked "fan off," and nothing happened. I then tried using the arrow buttons to move the print head, and nothing happened. I went back to the homepage, and tried to heat up the bed by clicking the dropdown and selecting PLA. After a few seconds, i got an error that the printer could not heat up.

Any ideas why I can't control anything? If it helps, I have the TH3D unified firmware installed, and the rest of my CR-10 is stock.

We cannot even begin to help you without logs.

I'll get those logs and post them as soon as I get a chance.

So, I'm a huge dumb idiot.....

Apparently, the motors and heaters won't work if the power supply isn't turned on...who knew? :wink:

The display lights up and the control board will talk to Octoprint, though.