Octoprint won't launch with Prusa I3 MK3S

What is the problem?

Ok, so here's my story, so i tried to attached a raspberry pi zero W with my prusa MK3S following this guide https://manual.prusa3d.com/c/Octoprint_for_Original_Prusa_i3_MK3, i followed everything meticulousely using the special prusa octoprint version and end's up with octoprint working properly and i finished the setup with the wizards on octopi.local.

Here's the thing, on octoprint there was a popup for a software upgrade, so i said "why not" and click on it, everything went downhill since, the upgrade never ends properly and i couldn't connect to octoprint with octopi.local anymore.

What did you already try to solve it?

1.I tried to reflash prusaprint on the sd card multiple time and start from the beggining
2.I also tried to flash the original octoprint version without success
3. I reset my printer to factory settings
4. I tried to toggle off and on Rpi port
5. I tried to resoldered properly pins on the raspberry pi zero w

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

  1. The printer won't display the IP of octopi anymore
  2. When i try to connect to octoprint it ends up with a timeout

Concerning the log i'm a novice so i don't really know where to gather this log

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)

Printer : Prusa i3 MK3S
Printer firmware 3.7.2
Browser : Safari
Operating system : Mac OS or iOS 12
Octoprint Version : PrusaPrint last version on 10/08/2019

Hi @Kashimi

Just click the blue word Logs a few lines before...
And: The serial.log is quite useful in this case.

well i can't access octoprint so i can't under "loging" dialog, and the logs inside the sub folder of configuration directory i can't find any folder on the micro sd about logs.

When you reflashed and it did not work, I assume the SD card is faulty.

1 Like